PDA

View Full Version : Welcome Home



bfisher
06-20-2011, 03:06 PM
Welcome back guys. I want to be the first to say that I was wrong about the subforums. As admin I can see them, but when I log on as a guest all I see is the Tech Forum and Traditional as they were prior to the meltdown. However, I got reinstated as an administrator and it appears that my duties and permissions have been expanded, at least to some degree. We'll see how it goes, but for now let's just enjoy the moment.

Barry

Destroyer
06-20-2011, 03:17 PM
Yes, good to be back. :D

And with a few improvements too!

gravedigger
06-20-2011, 03:37 PM
nice to be back in action

bigredhunter00
06-20-2011, 03:40 PM
woooooooooohooooooooooooo we are back!!!!!

Hutch~n~Son Archery
06-20-2011, 03:52 PM
Its nice to be back. Anyone using firefox browser no matter what I do it still shows that old message.



HUTCH:cool:

bfisher
06-20-2011, 04:05 PM
Its nice to be back. Anyone using firefox browser no matter what I do it still shows that old message.



HUTCH:cool:

Hutch, try logging onto Martin's website. Then click on Tech Forum there and see what comes up. That's how I got here about an hour ago.
If it works then just bookmark it.
Barry

Arrow Splitter
06-20-2011, 04:06 PM
YEAH!!!!!!!:cool::cool::cool: A REAL forum!

A.S

Hutch~n~Son Archery
06-20-2011, 04:12 PM
Hutch, try logging onto Martin's website. Then click on Tech Forum there and see what comes up. That's how I got here about an hour ago.
If it works then just bookmark it.
BarryTried that Barry. It still comes up with that dumb page. I copied and pasted the new address to my book mark now I am all set.


Hutch:cool:

Money Man
06-20-2011, 07:43 PM
Its nice to be back. Anyone using firefox browser no matter what I do it still shows that old message.



HUTCH:cool:

I use firefox and I did not see that old message. What a treat to see that things are back up and running.

Destroyer
06-20-2011, 09:13 PM
I use firefox and I did not see that old message

Same here. http://martinarchery.com/mtechforum

alex
06-21-2011, 02:08 AM
I'm so glad that our forum is back in action, stronger and better then ever :D

wick
06-21-2011, 04:48 AM
Soooo glad to have the forum back! :D

bigbob29
06-22-2011, 11:16 PM
Great to see the site back up and running. We have had serious issues over here too with one popular bowhunting site down amongst 48oo other sites. Seems the host company didnt have any off line backup system and there are a lot of very angry people who appear to have lost all personal data. The bow hunting site also seems to be irretrievable.Sure some sick little puppies running around.