PDA

View Full Version : trouble with cheetah



601fisher
08-01-2011, 04:51 PM
For the second time now in 2 yrs, the draw module has busted on my 2010 cheetah. Im wondering now if its not the limbs or riser that's to blame. They replaced my cam last year when this happened do it was only a year old and shot less than 400 times easy. Today it sheared off the edge of the module and some how tore off the plastic spacer in between the cam and the limb. Any knowledge of this problem or did I just get a bum now by luck of the draw?

HawgEnvy
08-01-2011, 05:31 PM
never heard of the problem before. Hope you get it worked out. Cheetahs are an excellent bow.

bfisher
08-01-2011, 06:01 PM
I've seen one or two plastic mods give it up over my shooting career of 38+ years so I'd really call it freaky. If you have a dealer nearby you could take it in and he/they should be able to fix it up.. If that isn't in the cards then call cusomer service at 1-800-541-8902 and see what they advise. Best to ask for Joel Carter in the warranty dept. He should take care of you.

By the way, welcome to the Tech Forums. I see we have the same last name. I knew there was something I liked about you. Any more questions, this is the place to look for help.

Barry

pizzadave
08-02-2011, 02:55 AM
I had the same issue with my 2010 Cheetah... I bent the cam module right over... The result was cracked limbs for me. I had an extreme amount of cam lean happening at full draw, which was putting a lot of pressure on the side of that module.... That little pice of plastic was the only thing keeping my string from flinging to the right..... I just got my bow back from getting warranty work done. I now have new limbs and a METAL cam module. I don't see that metal one breaking down half as easy as the plastic. Take a good look at your limbs for hairline cracks.. and check out the lean coming off of the cam module when you are drawing back, you may be surpised how ugly it looks..

601fisher
08-02-2011, 04:54 AM
Thanks for everyone's responses. Headed to a shop with it today. I think your right about the cam lean, I've always said it looked a little off when I drew it back, but then again I was looking down it and the other people always said it looked fine. I can't see any other reason for that module to break twice in two years unless there's a lot of pressure pulling on it. Guess next time if I think it off I'll just go with that feeling!

polaris754
08-02-2011, 01:40 PM
imho me thinks the cam mode screws loosen up and FAILURE just my opinion, had it happen on my saber loctite it next time out , good luc