PDA

View Full Version : Problem w/ Saunders Hypderglide... who's got um?



pizzadave
08-29-2011, 06:30 PM
I was out shooting a bunch last weekend... and when I hit about.... shot #100 using my Hypderglide. it seems to make a rattle noise when I shoot. It isn't awful, but it definitely is noticeable, and I'd like to know if anybody is using this slide, and if so, have they had this issue? Any suggestions on how to quiet it down? I am thinking that I may be ok to leave it the way it is, because by the time a deer hears it... it should be hit already... :P

Destroyer
08-29-2011, 06:44 PM
I have no problems so far. Is the noise there drawing the bow then letting down or just when you shoot? Make sure the rod And slide are clean and make sure its clipped together correctly.

Is it a creaky sound?

droppixel
08-30-2011, 04:36 AM
No problems with mine and I have shot the living h*ll out of it. I would check the plastic and see if the connection is good. Worst case, I would think you could pop it out and check the roller and the o-ring. Hopefully it isn't anything major, but I love mine and I feel like it has made a big difference over the OEM.

pizzadave
08-30-2011, 06:08 AM
It makes a rattle noise, and only when I shoot... very quiet in draw and let down. I will take it apart and make sure it is clean...

HawgEnvy
08-30-2011, 06:11 AM
never had a prob with mine in any way. smooth as silk and very quiet

bfisher
08-30-2011, 08:34 AM
Make sure the set screws hold the rod are tight, too. And check the screws hold the modules. In fact, check every not, bolt, and screw on the bow. Sometimes noise isn't where it appears.

Destroyer
08-30-2011, 02:43 PM
It makes a rattle noise, and only when I shoot... very quiet in draw and let down.

Could be the roller playing up, hope not. Mine just started making a creaking noise yesterday, not impressed.