PDA

View Full Version : My limbs are creaking...what lube to use?



CarlosII
03-15-2012, 02:50 AM
title says it all. my Shadowcat creaks when i draw it. need to grease up the limb pivots but wondering what's the best stuff to use.

Speedykills
03-15-2012, 03:09 AM
I use AGS white lithium grease..........

bfisher
03-15-2012, 05:03 AM
Carlos,

In the Roto cup there are two pads that the limbs sit on. Sometimes these are where the creaking comes from, The limb flexes as it is drawn and if there isn't sufficient lube between these and the limb creaking can occur. My Alien Z does it the first time I draw it on any given day. I know it doesn't mecahnically hurt anything and it's not a hunting bow so I don't worry about it, but if were a hunting bow I would take care of it. Just pointing this out as you may as well lube everything while you have it apart.

Tosi
03-15-2012, 10:40 AM
I too had some creaking from the limbs of a new 2011 Fire Cat 400. Tried lubes, replaced roto cups and replaced rest. After all that the creaking/cracking was coming from the top Cam bearings. I thought for sure it was the limbs. This would happen right before full draw. Martin CS sent out two Cam and no more issue.

Hutch~n~Son Archery
03-15-2012, 03:11 PM
title says it all. wondering what's the best stuff to use.Ben-gay when you are that old:p

Hutch:cool:

CarlosII
03-15-2012, 04:18 PM
Ben-gay when you are that old:p

Hutch:cool:

thanks... i needed that...

Thermodude
03-17-2012, 02:04 AM
I too had some creaking from the limbs of a new 2011 Fire Cat 400. Tried lubes, replaced roto cups and replaced rest. After all that the creaking/cracking was coming from the top Cam bearings. I thought for sure it was the limbs. This would happen right before full draw. Martin CS sent out two Cam and no more issue.

I was shooting my Onza last night and it started doing the same thing from what I thought was the top limb. Took it apart and cleaned it up then regreased everything, the light popping sound is still there plus as I let down the draw I have a squeak...........99% sure its the top cam bearings. Its my hunting bow and not my 3d rig so I dont need it right now but it was really dialed in and shooting great...........go figure!