PDA

View Full Version : what causes a cable slide to break



timbow
04-06-2012, 12:22 PM
I had mine break so i bought a new one for 20 bucks. had it on for a month and it just broke today Wtf. It was a alpine slide.

Lung Buster
04-06-2012, 12:32 PM
What bow do you shoot? Could you post some pic's of how it broke?

timbow
04-06-2012, 01:15 PM
I shoot a 2010 cheetah. It broke in the same place as my last one right in the middle between Where the strings are held and Where it slides on the rod.

timbow
04-06-2012, 02:01 PM
I think im gona get a sims limbsaver slide it looks really strong.

timbow
04-06-2012, 02:02 PM
Ya its wierd i reply to my own posts. Ha ha

Lung Buster
04-06-2012, 02:02 PM
I have a 2010 bone hunter aka cheetah and have not had any problems. That is strange. Is there any thing on the cables that could be coming into contact with it on the release?

timbow
04-06-2012, 03:50 PM
No Nothin on the string maybe too much pressure from the strings somehow?

bfisher
04-06-2012, 03:59 PM
Most of the OE ones are some sort of plastic so it happens. The Simms Teflon one should be a good choice. I have one that's on it's third bow.

Speedykills
04-06-2012, 04:09 PM
No Nothin on the string maybe too much pressure from the strings somehow?

I think your on to something,you might have it to far to the right!.I dont think ive ever had that happen to a bow ive owned.....

timbow
04-06-2012, 04:22 PM
If your talking about the rod its just a straight rod no adjustment.

Lung Buster
04-07-2012, 01:06 AM
If your talking about the rod its just a straight rod no adjustment.

I would try a teflon slide like bfisher said it might just be fethching up on the rod

Thermodude
04-07-2012, 02:13 AM
I would try a teflon slide like bfisher said it might just be fethching up on the rod


A couple weeks ago I was at a 3D shoot and as I drew my Pantera I could feel that there was a drag somewhere. I looked everything over pretty much after everyshot from that point on and didnt find anything wrong. After I got home I worked with it for about an hour , I took the OEM slide off and noticed that the side that was in contact with the rod was starting to show signs of galding. I was surprised at this becuase I use teflon spray and I rub all this down at least once per week. Anyway, I had a couple limbsaver slides down in my shop so I replaced the bad one and went ahead and replaced the one on my Onza as well. That took care of the problem.

Tosi
04-07-2012, 06:08 AM
look @ the Sanders Hyper Slide, have them on all my bows and they realy work well. Have read that the Hyper will add a few fps.

timbow
04-07-2012, 07:58 AM
My rod does Show signs of wear im gona turn it and see if it helps.