PDA

View Full Version : Fury XT Cam problem



Txcatshooter
02-22-2013, 07:50 PM
my cougar fc with xt cam made a click on full draw tonight, and the vibration popped the arrow off the string . I let off and found the string frayed where it looked like it was rubbing on the cam. It wore through the serving and thought that was the pop I felt. Put in a press and checked cam alignment and for looseness and found nothing out of line or loose. took it out and drew it a couple more times with the same pop.
any ideas on what it may be? At rest everything looks normal. I have the cams set at -10 and bolts out about 4 turns to 53 lbs for shooting indoor target since new. it about 2 mos old with less than a 500 arrows thru it.
thanks

wscywabbit
02-22-2013, 09:30 PM
First off welcome to the forum.

Secondly, it sounds like you may have a couple things going on... your draw may be set wrong; at full draw are you binding the cable against the cam's axle? You need to set it so that at full draw you are not touching.

There are many things that can make the type of sound you mention, check to make sure that you're draw stop is tight, check your mod screws, maybe one is sticking out a bit? If you have a drop away rest, is it set correctly or the cable shift on you?

If you can get someone to watch the cam and listen while you draw or put it on a draw board you could probably isolate the sound better. Good luck and let us know what you find (it helps us all learn what to look for on occasions like this :))

Jake-the-snake
02-22-2013, 11:07 PM
Also take a cotton swab and go over the limbs with it. If there are any cracks or splinters the cotton will catch on it.

Pyro
02-23-2013, 12:25 AM
Just some silly thinking but is the lil ruber cap still on ur draw stop? Mine is lose and falls of ocasionly and i get a click right at full draw as it hits the limb

spanner
02-23-2013, 01:42 AM
my cougar fc with xt cam made a click on full draw tonight, and the vibration popped the arrow off the string . I let off and found the string frayed where it looked like it was rubbing on the cam. It wore through the serving and thought that was the pop I felt. Put in a press and checked cam alignment and for looseness and found nothing out of line or loose. took it out and drew it a couple more times with the same pop.
any ideas on what it may be? At rest everything looks normal. I have the cams set at -10 and bolts out about 4 turns to 53 lbs for shooting indoor target since new. it about 2 mos old with less than a 500 arrows thru it.
thanks

Seems to me that your string may have gone behind your mod , the mods on the fury xt are know for coming loose , l fixed my screws with lock tight with nil problems since. Bow string must have got caught on something for the arrow to come off your string. Just a thought and a suggestion hope you can work it out soon.

nestickslinger
02-23-2013, 09:28 AM
Hey txcatshooter, Did ya find out what was making a click sound yet ?

Txcatshooter
02-23-2013, 02:37 PM
Decided to strip the bow and remove all accessories including the rest I was shooting a nap apache and thought the possibility of the lift line
being too tight which wasn't the cause, so with a bare bow I pulled it again and it popped again. The set up is fine and everything is tight
the module is set correct. I wish I had access to a draw board. it draws fine and pops when it starts to cam over. I'm afraid to pull anymore
because the string is worn half way through. I'll contact martin monday and feel them out and hopefully send it in and let them look at it.
I'll take some pics after the race and post, maybe you can see something I can"t
thanks for the help

I didn't realize it was my first post, I've been lurking here for months and searching more than anything, I hate asking redundant questions.
I've been shooting for two months now after 20 years of not shooting. I was right handed and gave up archery years ago from having nerve damage in my rt eye.
My son wanted a bow so I got him one and the shop I go to let me try out a LH bow and it was like riding a bike only on the wrong side of the road... I guess I'm hooked again as a lefty...

Txcatshooter
02-23-2013, 04:27 PM
okay i feel like a dummie, went to take pictures and noticed one cam screw was backed out and caused the pop on the draw, I tightened and drew
and it worked fine, I am set at -10 and have the 3 lined up which is 28.5 draw length, I am a 29 in draw and have the draw stop at about half way between the plus and minus. I pulled it back and found the string is not hitting the axle so the draw stop and cam were set correctly.
the string is frayed and serving broke where it lays on the cam at the end that was loose so I am assuming the cam was bowing out and pinching the string which wore through. Unfortunately there are no martin dealers for a few hundred miles from where I live so I'll order a new string and give it a try again. I shoot leagues on tues nite so not to let my team down I went out and bought another bow. Now I'm stuck with 2 bows and a new payment on my cc which was at zero. oh well live and learn. Thanks for all the help and especially with the new bengal thread it cleared it all up

nestickslinger
02-23-2013, 07:34 PM
Glad ya got it figuerd out.

wscywabbit
02-23-2013, 10:16 PM
Glad you got it figured out, it usually is something simple if it ain't broke. Also, I'm glad to hear that you recently returned to the sport and learned some new tricks! Old dogs and all that :)