PDA

View Full Version : Moab pro-hunter



jrags
02-25-2008, 02:05 PM
just wanted to start a thread for the Moab,

still learning the bow myself, starting to group but tend to stay level but about 2-3 inches left of bullseye,, most likley me, any tips would be welcome. :)

flytier17
02-25-2008, 02:14 PM
Move your sight pins left in gradual increments.

flytier17
02-25-2008, 02:15 PM
Congratulations on your bow, and welcome to the wonderful world of Martin Archery!

QUIVER
02-29-2008, 07:14 PM
Hey there, I'm new on the block. Just got a Moab. Love it! Smooth. Light.http://martinarchery.com/mtechforum/images/smilies/smile.gif
:)
Easy to set the sight pins. My only issue thus far is some cracking on the limbs
that appear to be the finish but not sure. Any one else seeing this? Or is this more serious an issue?http://martinarchery.com/mtechforum/images/smilies/confused.gif
:confused:

jrags
02-29-2008, 08:10 PM
You may want to let the dealer take a look at that, nothing showing on my new one yet,, but will keep an eye out for it.

QUIVER
02-29-2008, 08:39 PM
Thanks for the reply. The cracks on my bow are on the inside/underside of the top limb
across the entire width. the top one is by the pivot point of the limb. the lower limb one is covered up by the limbsaver adhesive base. If you aren't specifically looking for them they can look just like the camo. A friend here has a firecat thats doing the same thing. If I find out anything I'll let you know.

jimbow
03-09-2008, 02:14 PM
Picked up my new Moab yesterday. Having trouble with the peep staying aligned....string seems to be twisting. Also, it didn't come with the STS attached so I'm getting a lot of extra "twang" at the shot. Dealer is going to install the STS next week, so hopefully it solves the problem. When I test shot the bow in the store, it had STS and seemed very quiet. Don't know what else would cause the noise. Thoughts???

Montalaar
03-09-2008, 02:57 PM
The string should settle down within the next ~300 shots. The noise can have several causes but you may want to wait for the sts to be installed.

QUIVER
03-09-2008, 05:30 PM
Hey there, my Moab's peep did the same thing. I played with the d-loop and it seems to be working now. I've had my bow for two months. When I first got it it seemed to have some vibration you could hear and not really feel. I put rubber tie on string vibration reducers along with the ones the bow comes with, sound went away. After you get the kinks out enjoy the bow, its awesome!