PDA

View Full Version : Dyna Cam String Breaks



remolino
09-16-2008, 09:01 AM
The string on my Jaguar Dyna Cam broke, while I was at full draw, under the serving right at the peak of the Dyna Cam draw length module.
The bow is less than a year old, the cams have never been rested on the floor, always on a stand or in the bow bag, and the string itself has been waxed a few times in the past 9-10 months.
The module I use is an F7 adjusted by the cam pegs to 29.5" which has a fairly acute angle on the peak.
I noticed on this forum that another couple of bows, also with dynacams recently suffered the same problem.
I would be interested to hear from people who may have had the same or similar problem and what module they use. As the modules have slightly different profiles, this may only affect certain draw lengths.
The bow came apart at full draw next to my face and the carbon/ally arrow snapped clean in two. Luckily all the parts flew away from me and not towards anyone else either.

Thanks,

~Austin~
09-28-2008, 09:01 PM
I have an '05 Jag. on which the serving of the cable ( directly where it rolls over the adj. module) was not wound correctly, leaving a couple of spots of bare string showing. I called tech support and was told it wasn't a big deal as long as the string wasn't wearing. As I have read several posts here that talk of breakage at that point It's starting to look like a factory defect on that perticular model. I'm sure Martin doesn't agree, but if it walks like a duck and quacks like a duck.........