PDA

View Full Version : 08 firecat



eldermike
03-27-2009, 04:03 PM
The cam module groove is offest from the cam groove. After only a few shots the serving on the cable is wearing on one side. It has to follow that offset which seems odd to me. Is this offset normal?

eldermike
03-28-2009, 06:58 AM
A better picture.

eldermike
03-30-2009, 06:30 PM
I spoke to Martin by phone today. I was told the alignment looked ok. I explained the fraying on the cable and what I did to fix it. I took the modules off the bow and stoned the sharp corner off the backside of the groove where it meets the flat. That did the trick and the fuzzing on the serving stopped. Martin was ok with my repair. I also ran this by the tech at the closest pro shop Martin dealer(45 min drive). He said I did the right thing. He also said it would break in on it's own, but at the cost of shorting the life of the cable.

The bow shoots great. I am shooting it at 55 lbs, 28 inches, 363grain 45/60 arrow. My crony said it was doing 265fps. That's fast for that draw weight and length. With an HHA 5000 sight and Throphy Taker spring steel rest it's going to fun to shoot some fun 3D and informal spots with it.

bd09firecat
03-31-2009, 06:59 PM
just thought you would like to know i have the same problem with my 09 firecat . that rear edge is razor sharp and has cut through all of the serving on the cable in only 500 shots . i took the bow in for repair but i plan to do the same thing to my mod if there is no better fix, just didn't want to file or stone my three week old mod before taking it to a pro shop .

HungarianHammer
04-01-2009, 06:38 PM
Same thing on my mod but for the M pro2 cam