PDA

View Full Version : Cable Wear on Cheetah



Hoosieroutdoorsman
07-13-2009, 06:02 PM
I sent a message via the contact us and the response I got either they didn`t understand the question or I worded it wrong. I have an 09 cheetah, the cable serving is wearing badly after about 50 shots, when you draw you can see the cam is leaning over into the cable and rubbing it. I got the idler lean taken care of before I ever put a shot on it, I have the 5L limbs and talked with 2 pro shops and they said the cam lean was due to the light limbs, I needed 5H limbs and the problem would be solved, is this correct info?

Jake-the-snake
07-14-2009, 07:36 AM
i dont think new limbs would help, as all limbs can and will have cam lean, now what do you mean by cable wear??? some pictures would help greatly:)

Elk4me
07-14-2009, 04:30 PM
Tracy post some pics buddy then we can see how we can help you out!:cool:

Montalaar
07-15-2009, 12:51 AM
The limbs can have an effect on cam lean, that is right. But a higher limb rating (5H) would lead to a higher drawweight and i do not think that you really want that.

Please check if your limb tips are uneven and produce some lean.

SandSquid
07-15-2009, 10:52 AM
talked with 2 pro shops and they said the cam lean was due to the light limbs, I needed 5H limbs and the problem would be solved, is this correct info?

I say they are blowing smoke up your a.....

Hoosieroutdoorsman
07-15-2009, 03:53 PM
The wear is from the buss cable rubbing the outer rim of the cam during full draw, it is wearing it to the point the serving needs replaced, I am going to get an offset cable guide to take some of the tension off. I went over it with a fine tooth comb and with the stock cable rod the cable and string are pulled majorly to the side, it even has my teflon slide egg shaped which should not be. The limbs are 70 lbs limbs set at 65 lbs so it isn`t a matter of being set to tight.

Hoosieroutdoorsman
07-30-2009, 02:13 AM
I did some investigating and found a easy solution if anyone else is having the same issue. On the cam bushings there is a white spacer on the right bushing, take it out and move it to the left bushing, the contact issue is gone and the cam rotates smoother.

Montalaar
07-30-2009, 02:49 AM
Hey, thanks for your tip.

If you are able to post some pictures we would be glad to see that!

Hoosieroutdoorsman
07-30-2009, 03:38 PM
the bow is all back together pictures wouldn`t show anything other than the normal cam and limb. You just press the bow and remove the cam axle and take the thin white washer from the right side and place it between the black bushing and the limb on the left side of the cam or the draw stop side if a right handed bow and put it back together.