PDA

View Full Version : cam problems with 08 bengal.



stuntmanstunter
10-24-2009, 08:45 AM
i am a very picky guy when it comes to my bow and about a week and 1/2 ago i thought i bumped my cam on the deer stand when i was lowering it down. i visual looked over my cam and seemed that there is a machine flaw in it. where the string goes in the grove on one side is thicker than the other. on the left side of the string grove, the lip is not even paper thin. i took it to my archery shop and he examined it and said that it was a machinist flaw and it was dangerous cause it could cut my string. another problem is i have been trying to contact martin to either buy or see if they would replace it for me and a week and a half has gone by with me leaving a message every day and no one has called me back.

Montalaar
10-24-2009, 09:36 AM
You could go to the shop you bought the bow from and ask them to get a replacement cam. As your bow has lifetime warranty you should get that one for free.


The people at the plant might be very busy at this time as the whole new lineup has been announced this days.

stuntmanstunter
10-24-2009, 11:51 AM
i bought the bow off ebay from a archery shop in a different state. myt local archery shop is a mathews and bowtech dealer

bigbob
10-24-2009, 02:29 PM
I have posted the same type of problem with an older model but it is in the cable groove rather than the string groove. One side is very thin and the module has little or no radius leaving an edge that chewed my cable.

brushrat
10-24-2009, 02:36 PM
i bought the bow off ebay from a archery shop in a different state. myt local archery shop is a mathews and bowtech dealer

they can and will ship parts to any bow shop, whether you bought the bow there or not. You need to have your archery shop agree to help you do this, though. Be prepared to show a copy of your sales receipt. Sounds like you have a very legitmate request for a new cam. Good luck:)

stuntmanstunter
10-25-2009, 06:03 PM
i have so much trouble trying to get a hold of a real person with martin, and i have been leaving messages on there machines and no one has called me back.

stuntmanstunter
10-25-2009, 06:10 PM
I have posted the same type of problem with an older model but it is in the cable groove rather than the string groove. One side is very thin and the module has little or no radius leaving an edge that chewed my cable.

from were the cable first starts in the cam almost half way around my cam is alot thinner than paper on just one side. my cable is starting to fray to and the archery shop i go to told me that the cam is so thin on one side that it could act like a razor and cut it at any moment. i am now scared to hunt with it but it is my only bow.

bigbob
10-26-2009, 12:15 AM
my original module was alloy and has a thin edge but never had any trouble with cable. Present module is fibre, has no thin edge but doesnt line up exactly with cam groove where the module and cam butt up to each other so it is chewing my cable serving. Your problem seems similar but a little different. May just be that it is a production fault in cam or module, but hey I'm just a guy who knows diddley squat about the newer bows.