PDA

View Full Version : Warthog help



Oregonhunter78
12-15-2009, 07:20 PM
Hi, i have a question about my warthog i just bought. I tried to change the draw length to the #3 position on the mod and found out the hole was not drilled right. The screw will go in easy but it goes in at a angle. The #3 hole is the only one thats messed up and its the one i need. Do i have to go to my dealer to get a new mod? I live 75 miles away from my dealer and it has been snowing hard for the last to days. Thanks for any help.

ezbite
12-15-2009, 07:34 PM
i just got a new module last week and my #3 hole is also out of alinement. im off tomorrow and im taking it back to the shop as soon as hes open. ive been having module problems with my firecat since i got it. same module had #1 hole stripped out the day i brought it home frome the shop, not sure if my pro stripped it while we were setting it up or if it came from martin like that(very doubtful its the second part of that statement:rolleyes:). if you look at this picture, you can see my one screw is bottomed out and #3 is off alinement. is this what yours looks like. i cant get it to go in, so back to the shop i go.

take it back to the shop, dont try to fix it yourself. they most likely have another on hand.

Oregonhunter78
12-15-2009, 07:41 PM
Thanks for the info. Mine is not stripped, it just looks like the hole was drilled at an angle. The screw threads just fine, but at a angle. Im sure it would be covered under warranty but i would pay for one to save me a trip on the bad roads.

bfisher
12-15-2009, 07:58 PM
How about just call the shop and explain. Then he can order you a new one. When it gets there just mail each other your respective modules.

Oregonhunter78
12-15-2009, 08:05 PM
How about just call the shop and explain. Then he can order you a new one. When it gets there just mail each other your respective modules.

Yep, i will give that a try tomarrow.

Oregonhunter78
12-15-2009, 08:13 PM
If anyone has a mod for a 09 warthog for sale please let me know.

ezbite
12-15-2009, 08:24 PM
If anyone has a mod for a 09 warthog for sale please let me know.

you'll need to say if its the upper or lower, they are different.

Oregonhunter78
12-15-2009, 08:48 PM
you'll need to say if its the upper or lower, they are different.

For the top cam. Thanks

Oregonhunter78
12-16-2009, 05:03 PM
Does anyone know if the 08 cat cam mods are the same as the 09 cat mods? I drove all the way to my dealer today and found out what the problim was. My mod was bent. He gave me a new mod from a 08 firecat and said they were the same. They look the same, all the holes line up perfect. I just noticed the 08 mod looks just a very little bit thicker. Did they change the thickness of the mod between 08 and 09? Thanks again for anymore help.

ezbite
12-16-2009, 05:15 PM
my new replacement module from martin was thinner than the ones that came on the 2009 firecat. we had to replace both to get them the same size. the ones that came from factory orginally installed, the screw was flat to the module when bottomed and these newer ones about 2 threads stick out past the module. should be able to see it in the picture above.

Oregonhunter78
12-16-2009, 05:31 PM
my new replacement module from martin was thinner than the ones that came on the 2009 firecat. we had to replace both to get them the same size. the ones that came from factory orginally installed, the screw was flat to the module when bottomed and these newer ones about 2 threads stick out past the module. should be able to see it in the picture above.

ezbite, thanks again. Sounds like i may have to take another trip into town. This is starting to get very fustrating.

bfisher
12-16-2009, 07:26 PM
No need for a trip to town. Give it a try. If the cable serving doesn't rub the module you're OK.

Last year Martin was having some issues with the module rubbing the cable when the bow was drawn. This, of course, rubbed the serving creating premature wear. Some bows did it and some didn't. They supposedly had a fix for this and now I have an idea what it was. They just machined the module thinner a little bit. Probably by about 2 threads worth of metal removed. At 32 threads per inch those two threads would amount to 1/16" where I went to school.

Anyway, this modification must have worked as it now seems to be standard for 2010.

Oregonhunter78
12-16-2009, 09:57 PM
Thanks bfisher, your right! I went out in the garage and shot it about 50 times and all is good so far. Thanks for everyones help. I am happy now.