PDA

View Full Version : Need some help with my Martin



Punchfree_4L
09-04-2010, 04:13 PM
Here is my problem.I have an '10 Martin Cheetah,I wanted to replace factory strings with new ones so i ordered new string and cable.
Now before I continue,the new string and cable match with the old string as far as length.
soooo,I went to put new string and cable on and the buss cable has a ton of slack in it and the cam is wayyyyy out of where it should be.When i bought this bow(new)the ata was 29.5",the factory specs say the ata should be 30" for this bow but it shot great so I didn't mess with it.Now I have the new string and cable with this problem I don't know what to do,I even try to put old string back on and same thing happens.I have to be putting something on wrong.....don't you think?
Any ideas?

bfisher
09-04-2010, 05:40 PM
Dig out your owner's manual. I'll bet you have the cable and/or string routed incorrectly on the cam. Can you post a picture?

Punchfree_4L
09-04-2010, 06:25 PM
1273

1274

Notice the slack in the cable?

Destroyer
09-04-2010, 06:45 PM
Looks like the cables are way too long or the string is way too short. Twist the cables up so the bow specs are correct, not to the string spec length.

bfisher
09-04-2010, 07:06 PM
You take nice pictures, really. Now back off a bit and show the bottom half of the bow. Although the pics are good it looks like you still have the Bowmaster compressing the limbs. Let the tension off almost the whole way so the cam can rotate into position.

Punchfree_4L
09-04-2010, 07:30 PM
Actually the bowmaster is backed off,thats where the cam sits now(not where it was before)its gotta be that i didn't put the strings on right because the cam doen't turn at all when i try to draw bow.

Destroyer
09-04-2010, 07:36 PM
the cam doen't turn at all when i try to draw bow.

Oh my. :eek:

Punchfree_4L
09-04-2010, 07:38 PM
1275

This is backed off pretty much so tension is on string.New string and cable is on.

Destroyer
09-05-2010, 12:15 AM
Download 2010 manual here. http://www.martinarchery.com/manuals/


the buss cable has a ton of slack in it

Not surprising, string isn't routed correctly. Missed that one as well, that's two stuff up's today lol!

Punchfree_4L
09-05-2010, 06:14 AM
Thanks Destroyer,that manual helped a bunch.The manual i got with the bow showed different cams so that was throwing me off.
All good now thanks guys for your help.

bfisher
09-05-2010, 05:56 PM
OK, so I assume you have it all together now. How's it shooting?

Punchfree_4L
09-06-2010, 06:52 AM
Gotta get everything back on like peep,d-loop and all that jazz.Just glad to get it back together.
Our season is a little more then a month away,but I like to shoot alot so I want to get it dialed in asap.

Destroyer
09-06-2010, 06:05 PM
Good to hear its back together, any more questions just ask. We like to help here. :)