Results 1 to 7 of 7

Thread: question on saber se cable slide

  1. #1
    MRHAPPY
    Guest

    Default question on saber se cable slide

    hi, new to forum,i got new 2006 saber se, should the buss cables be touching the string above the cable slide? how do i fix? had some idler wheel lean and fixed most of the lean but cables still rubbing (put new custom strings on didnt help

  2. #2
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,584
    Post Thanks / Like

    Default

    I assume you have the DynaCam. The cable slide is a "stepped" model meaning it separates the cable and the string. It's possible your's is on the slide backwards. If so it's easyenough to fix. You can just muscle it off the end of the rod, turn it around and put it back on with the cable/string installed correctly.

    Or it's possible that the string and cable are just in the wrong slot with the slide the way it is.

  3. #3
    MRHAPPY
    Guest

    Default

    thanks , i have tried all ways of different things turning cable slide around and putting each string on the other one etc, either rubs below the cable rod or above it? yes dyna cam

  4. #4
    MRHAPPY
    Guest

    Default

    the longer end of the offset goes towards riser correct? i have tried both ways

  5. #5
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,584
    Post Thanks / Like

    Default

    Without having one in front of me I can'tsay. I do know that the cables should cross above the cable guard with the DynaCam. In fact I think all singlecams are this way, at least the ones I've seen and had,

    Sorry I can't help more, but I'm away from home and have no bows to look at right now. Sounds like you may need to get on wwwarcherytalk.com and PM PUG or JoelC. They are Martin employees and can help you out.

  6. #6
    MRHAPPY
    Guest

    Default

    i twisted the y cable back to where it was befor i tried to fix cam lean and now there the strings aren't touching, but is some cam lean built into this bow for tracking etc? dyna cam ?

  7. #7
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,584
    Post Thanks / Like

    Default

    Cam lean is not built into any bow. It's just what you get when you have a single cam with no cable yoke to straighten it out. That and the cable rod pulling the cable.string sideways.

    Something to think about here. Many guys refer to cam lean and twisting a cable yoke when what they are referring to is the idler wheel. There is no yoke on the bottom limb to correct CAM lean. If the cam leans then you're stuck with it. If it's too severe then maybe it needs to go back to the manufacturer.

    Just one of the many reasons I don't shoot a single cam bow any more. But this is a personal matter with me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •