Results 1 to 7 of 7

Thread: Prowler Cable on cam

  1. #1
    Unregistered
    Guest

    Default Prowler Cable on cam

    i have a prowler... i know it is kinda old... but recently after i shoot the cable on the top where the "Y" hook on the limb ends up on the back of the cam ontop of the string./.... one dealer said maybe my limbs are weak.. i haven't lost any speed and this bow has probably only been shot maybe 200 times???

  2. #2
    Myk
    Guest

    Default

    Please rephrase the question.

    I don't see any way possible for what I'm reading you say what is happening to happen without breaking the bow down, disconnecting the cable, wrapping it around the cam and string and then reconnecting it.
    I doubt if that's happening while you are shooting so I'm not understanding what you are saying.

    Also how old of a Prowler, is it a cast riser or a machined riser?

    If you have a camera pictures are worth a thousand words.

  3. #3
    rettug
    Guest

    Default

    no it is not un-doing itself just coming to rest on the back of the cam... here are a few pics hope they help and thank you
    Attached Images Attached Images

  4. #4
    Myk
    Guest

    Default

    Wow, at least now I see what's happening.

    Could it be the cam leaning into the cable on that side?
    Is your string too long allowing the lobe on the cam to be out of time so it is able to catch that cable? The old website's pictures aren't from the right angle but it doesn't look like that lobe should bisecting the line from the axle to be able to do that.
    You might also have your cable guard adjusted too far out pulling that cable into the cam.

    I would guess that most likely is the string has creeped allowing the cam to be out of time.
    I'm assuming it's used with a lot more than 200 shots and the bushings could be worn causing cam lean but more likely it's one of the other things I suggested.

  5. #5
    rettug
    Guest

    Default

    welll. it wasnt used for more that 200 shots i doubt... it has hung in my house for like 9 years.... apparently the string had stretched under the serving... i was shooting the other day and the sting exploded... send chit everywhere.... so we will see when i get it back if i still have this problem... also i thightened the limb both down the whole way and it didn't seem like they were exactly drawn down even... after i did this it didnt seem like it was catching on there... but that string is toast now.. i will let you know... for anyone who hasn't had a string break while shooting.... WOW.. scares the turds right out of ya thanks for your help/.... also what is a good new bow to buy?

  6. #6
    Myk
    Guest

    Default

    Glad you weren't hurt.
    Yeah, having one go not only scares you, it gives you a new respect for checking and changing your strings.

    Mine was a cable on a non-steel cable bow. I think I got a little scratch/knot on my arm and had to spend a lot of time looking for stuff.
    I sure don't put off worn servings any more and if I notice an excessive amount of creep I replace it.

  7. #7
    rettug
    Guest

    Default

    new string fixed it... the string was stretched under the serving... Thanks for the info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •