Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Repeat problems with 2009 Cheetah

  1. #1
    Junior Member
    Join Date
    Jul 2011
    Location
    Central Illinois
    Posts
    17
    Post Thanks / Like

    Angry Repeat problems with 2009 Cheetah

    In December, 2010, I posted as an unregistered guest with the following problem on the forum with my cheetah:

    12-13-2010 06:45 AM #1
    Unregistered Guest
    Help with Martin Cheetah 2009

    Hey guys, I tried to register and it said it has been disabled by administration.

    Here is my situation:

    I have a Martin Cheetah, New for Xmas LAST year. 2009 bow.

    While on stand 2 weeks ago, I had a buck coming in and took the bow off the hanger and set it on my thigh to get ready and heard a small noise and felt the cam "give" a bit.

    Never noticed this so I was immediately concerned. Passed on the deer and headed back to the house as soon as it was clear.

    I shot several shots with no problems.

    If I place the cam in the palm of my hand and apply light pressure the cam SHIFTS upward, and when you let off the pressure it comes back down with a very faint popping noise. There is NO side to side movement, only vertical movement.

    I later noticed the top wheel does the exact same thing in the opposite direction. Is this part of the design or are the bushings already worn out? I have shot this bow very little as I had shoulder surgery in May and couldn't shoot from May to September.

    I took it to the local shop and they don't deal in Martin but said it would need to be sent back...OR...could be part of the design, the didn't know, they did note they have never seen one do this.

    I still have a month of season left here, just looking for some reassurance from Martin.

    Any ideas?

    Please Help,

    Corey Suter
    corey_suter@hotmail.com

    Thank you in advance for any help.


    Eventually I got in touch with Joel from Martin customer service. He was awesome and very professional with dealing with the problem. They worked with a local dealer and sent parts out as soon as feasibly possible during the holiday season.

    They replaced basically everything but the riser and my string.

    The down fall was I missed almost a month of late archery season on a bow that was one season old.

    The second blow was when I picked the bow up and had to pay $50! ($15.00 for shipping, $35.00 for labor). to cover the cost of a bow that was under warranty and broke in one year. That one was very tough to handle.

    And the major kicker...the bow is doing the exact same thing again. It seems to get worse with cold. I am at a loss. Don't want to miss another month of season, and don't want to pay another $50 to have it "fixed" again.

    looking for opinions,

    Should I just cut my losses and go to another brand or what. I am very frustrated, as I have been a faithful Martin guy since 1990.

    thanks,

    Corey Suter aka csgrizz

  2. #2
    String builder/ Super Moderator Hutch~n~Son Archery's Avatar
    Join Date
    Aug 2009
    Location
    Gilmanton, New Hampshire
    Posts
    5,787
    Post Thanks / Like

    Default

    Sorry to hear the problem is back. As far as any bow company goes you would have to pay the pro shop as they are not reinburst for the labor or the shipping. That is just one of the down falls in the archery world. The only alternative is to call joel and ship it there. One way shipping is all it will cost. But as for time lost not much you can do. But maybe wait till after season.




    Hutch
    Bow String Depot Custom String Builders
    Need a string set pm or email me @ bowstringdepot@gmail.com
    or check us out @ http://bowstringdepot.com

  3. #3
    Junior Member
    Join Date
    Jul 2011
    Location
    Central Illinois
    Posts
    17
    Post Thanks / Like

    Default

    Thanks for the input Hutch,

    I understand the cost, its just that at this point in my family life, I couldn't justify a higher priced bow, but if I have to send it back once a year for $50.00 a pop, I will reach a point where I spent the same money as a higher level bow. I guess I get what I pay for, or in this case my wife paid for. lol Always been a Martin guy, I will wait till season is over and give it one more whirl most likely.

    later,

    CS

  4. #4
    Senior Member elkslayer4x5's Avatar
    Join Date
    Mar 2008
    Location
    Lane County, Oregon
    Posts
    2,857
    Post Thanks / Like

    Default

    Quote Originally Posted by csgrizz View Post
    In December, 2010, I posted as an unregistered guest with the following problem on the forum with my cheetah:

    12-13-2010 06:45 AM #1
    Unregistered Guest
    Help with Martin Cheetah 2009

    Hey guys, I tried to register and it said it has been disabled by administration.

    Here is my situation:

    I have a Martin Cheetah, New for Xmas LAST year. 2009 bow.

    While on stand 2 weeks ago, I had a buck coming in and took the bow off the hanger and set it on my thigh to get ready and heard a small noise and felt the cam "give" a bit. Never noticed this so I was immediately concerned. Passed on the deer and headed back to the house as soon as it was clear.

    I shot several shots with no problems.

    If I place the cam in the palm of my hand and apply light pressure the cam SHIFTS upward, and when you let off the pressure it comes back down with a very faint popping noise. There is NO side to side movement, only vertical movement.

    I later noticed the top wheel does the exact same thing in the opposite direction. Is this part of the design or are the bushings already worn out? I have shot this bow very little as I had shoulder surgery in May and couldn't shoot from May to September.

    I took it to the local shop and they don't deal in Martin but said it would need to be sent back...OR...could be part of the design, the didn't know, they did note they have never seen one do this.

    I still have a month of season left here, just looking for some reassurance from Martin.

    Any ideas?

    Please Help,

    Corey Suter
    corey_suter@hotmail.com

    Thank you in advance for any help.


    Eventually I got in touch with Joel from Martin customer service. He was awesome and very professional with dealing with the problem. They worked with a local dealer and sent parts out as soon as feasibly possible during the holiday season.

    They replaced basically everything but the riser and my string.

    The down fall was I missed almost a month of late archery season on a bow that was one season old.

    The second blow was when I picked the bow up and had to pay $50! ($15.00 for shipping, $35.00 for labor). to cover the cost of a bow that was under warranty and broke in one year. That one was very tough to handle.

    And the major kicker...the bow is doing the exact same thing again. It seems to get worse with cold. I am at a loss. Don't want to miss another month of season, and don't want to pay another $50 to have it "fixed" again.

    looking for opinions,

    Should I just cut my losses and go to another brand or what. I am very frustrated, as I have been a faithful Martin guy since 1990.

    thanks,

    Corey Suter aka csgrizz
    I know that this will sound a bit crazy, but it sounds as if the axle hole in the limb tips are oval rather than a single hole, allowing the cam and idler to shift. Since you had the work done in a shop, I'm guessing that you did'nt get a look at the limb tips,maybe if you could back the bow down, (turn down the draw weight ) and see if you can twist either cam or idler, reproducing the shift? Just tossin rabbits here.
    http://eastoutfitter.tripod.com/index.html
    http://www.cascadianbowmen.org/
    Martin 06 Slayer, Nitrous C, shoot thru, 63lb, Quiktune 3000, HAA OL 5519, Beman ICS Hunter
    Martin 06 Slayer, Nitrous C, Shoot thru, 55lb, Quiktune 3000, HHA OL 5519 2X, Easton A/C/C
    Ben Pearson 1968 'Cougar' 62" 45#s @ 28" recurve, parallel shaft POC, Zwickey 'Eskimo' 2 blade

  5. #5
    Junior Member
    Join Date
    Jul 2011
    Location
    Central Illinois
    Posts
    17
    Post Thanks / Like

    Default

    Thanks again for the input, I have emailed customer service to see what they say.

    later,

    CS

  6. #6
    Junior Member
    Join Date
    Jul 2011
    Location
    Central Illinois
    Posts
    17
    Post Thanks / Like

    Default

    I talked with customer service via email, obtained an RMA # and shipped it back. They received the bow last Wed morning, so now it is just a waiting game.

    FYI, it cost me $19 to ship UPS to them with increased insurance...as opposed to the $50 for shipping/labor it cost me last time at the dealer.

    Thanks to all that had input, I will keep you posted as to how it turns out.

    thanks,

    CS

  7. #7
    Junior Member
    Join Date
    Dec 2011
    Location
    WISCONSIN
    Posts
    16
    Post Thanks / Like

    Default

    I had the same problem as you,,,after a run around, by the factory,,I sent my bow back to Greg @ hunting and fishing usa 251-943-5584 where i bought the bow,,he fixed what the factory experts couldn't.I almost gave up on the Martins,,,but now that it is properly fixed I love it.Give him a call,,tell him Mike from Wisconsin sent ya.He is the only guy I will EVER buy a Martin from and the only guy I will trust to fix it.If you want any further details,,,which there are many,,pm me,,,

  8. #8
    Junior Member
    Join Date
    Jul 2011
    Location
    Central Illinois
    Posts
    17
    Post Thanks / Like

    Default Bow is back

    The bow showed up at my house this past Friday night via fedex. So less than two weeks after sending it in. I was not contacted while they had the bow for questions or anything, but I did provide a typed detailed description of the problem.

    There was an invoice on the box that noted "couldn't find anything wrong, replaced the cam anyway, cables were crossed the wrong way." (cables that were put on by the martin dealer that did the work last time)

    That is troubling since it was making an obvious sound, even to non archers in the office.

    The strangest part is it isn't making the sound anymore. I did notice they cranked the bow all the way back down, wondering if that has something to do with it, as I had it backed out a couple turns due to shoulder surgery.

    Its shooting great, but its unsettling that they didn't find anything. If it happens again, I am going bow shopping.

    thanks for the input guys.

    CS

  9. #9
    Senior Member droppixel's Avatar
    Join Date
    Apr 2011
    Location
    Plano, IL
    Posts
    1,635
    Post Thanks / Like

    Default

    Quote Originally Posted by csgrizz View Post
    The bow showed up at my house this past Friday night via fedex. So less than two weeks after sending it in. I was not contacted while they had the bow for questions or anything, but I did provide a typed detailed description of the problem.

    There was an invoice on the box that noted "couldn't find anything wrong, replaced the cam anyway, cables were crossed the wrong way." (cables that were put on by the martin dealer that did the work last time)

    That is troubling since it was making an obvious sound, even to non archers in the office.

    The strangest part is it isn't making the sound anymore. I did notice they cranked the bow all the way back down, wondering if that has something to do with it, as I had it backed out a couple turns due to shoulder surgery.

    Its shooting great, but its unsettling that they didn't find anything. If it happens again, I am going bow shopping.

    thanks for the input guys.

    CS
    Think those are the 2 key pieces to this and your problems. Not all dealers may know what they are doing in my opinion. I would venture to say a lot of car salesmen can't change their oil, brakes or even put in new wiper fluid!

    If that was the exact note, it could have been written a little better, but hopefully this solves all the problems. Hate to see a Martin guy stray from the fam!
    2014 Lithium :: 2007 Cheetah :: Jaguar Take-down
    REAL AVID Field Staff / Bucks and Beards Scents Field Staff

  10. #10
    Junior Member
    Join Date
    Jul 2011
    Location
    Central Illinois
    Posts
    17
    Post Thanks / Like

    Default Update....continued problems

    As noted above, I received my bow back after it's second stint for warranty work for the same issue since Dec '10, with an invoice on the outside of the package noting the cables were crossed the wrong way (set up by authorized dealer)and they couldn't find anything wrong. It also noted they replaced the cam anyway.

    Due to bad weather and a 2 week old baby I haven't shot much, but as I was shooting at the end of this past week, I noticed if felt "long" in the draw.

    Decided to check, it had the F5 draw module in. I looked up the specs on the martin site for the accu trak, and F5 is 29". I had my bow set for 28" when I sent it in.

    I had two sets of modules, one opened, one unopened (dealer sent me a set after a delay in shipping on the original purchase) I checked my set of modules, and the F4 is missing, leading me to believe it was on the bow when I shipped it to martin.

    I had that other set of unopened modules...so no biggie, I just switched back to the F4 from the other set. Drew the bow and at about mid draw about when it is going to roll over...there is a loud POP!

    Please note this is NOT the same sound from before. I drew it several times and every single time at about mid draw it POPPED loudly. Switched back to the F5 module that was in it and it didn't make a sound.


    What gives? Is there a chance the modules are different for a left handed bow?

    To Martin's credit, the sticker on the bow says 29" draw...but this is why I would think a phone call may have avoided some confusion...or just sending it back with the same draw that was in it.

    I am tired of dealing with emails on this matter, so I wanted to talk with someone in person. Called yesterday and rec'd voice mail. Left message with my cell requesting contact. They didn't call yesterday, but not sure if they were open...us government employees had the day off so maybe they were closed?

    Final question...is there a lemon law for bows? This is the most frustrating experience I have ever had in the archery world.

    sorry for the long post,

    CS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •