Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: 2012 Bengal set up

  1. #1
    Junior Member
    Join Date
    Apr 2012
    Posts
    9
    Post Thanks / Like

    Default 2012 Bengal set up

    I just got a new Bengal and the Y cable was cut because it was rubbing on the middle of the cam, by the draw length adjustment mod. When I called Martin they said that it wasn't set up correctly. Sense I set it up I must need some help on the proper way to adjust draw length and draw stop. I currently have the mod at a 1 and the draw stop about 3/4 in away from the - side. The string is getting cut when it goes across the center of the cam. What are your thoughts?? The first picture is of the part where the cable is rubbing. The second two are where the other adjustments are.
    bengal 1.jpgbengal 2.jpgbengal 3.5.jpg
    Last edited by b_frazier; 04-30-2012 at 08:51 PM.

  2. #2
    Senior Member wscywabbit's Avatar
    Join Date
    Nov 2008
    Location
    Sultan, WA
    Posts
    1,567
    Post Thanks / Like

    Default

    first off, welcome to the forum!

    Secondly, a picture is worth a thousand words my friend. So if you can post some close ups of your cam we can help a bit easier... and faster
    In God and guns we trust;
    • One nation, under God, indivisible, with liberty and justice for all.
    • A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.


    2011 Onza 3: 70#, 28.25 draw (AMO), 384 gr arrow, 288 fps
    2005 Saber: 70#, same arrow, 250 fps

  3. #3
    Junior Member
    Join Date
    Apr 2012
    Posts
    9
    Post Thanks / Like

    Default

    How are those pics?? Do they help?

  4. #4
    Senior Member droppixel's Avatar
    Join Date
    Apr 2011
    Location
    Plano, IL
    Posts
    1,611
    Post Thanks / Like

    Default

    What is your draw length? In the #1 hole there isn't much room for cam rotation before the cable sets into the back of the module where it starts to taper down. I'm noticing that with mine as well and I have mine set on the #4. I'm trying to figure out where the best "stop" for this module is as well since it doesn't have a flat spot like the others I am used to so you know when it is seated where it needs to be. I know from what others have said so far that if the module is over rotated or the draw stop isn't set proper that is where the wear comes from. Trying to do everything I can to prevent that for as long as possible until I can drop some money on a custom set.
    2014 Lithium :: 2007 Cheetah :: Jaguar Take-down
    REAL AVID Field Staff / Bucks and Beards Scents Field Staff

  5. #5
    Junior Member
    Join Date
    Apr 2012
    Posts
    9
    Post Thanks / Like

    Default

    I'm about a 28 in. I've been playing with it a little and think at I may have figured it out. I moved the mod back to 2 and played with draw stop. It is no longer touching the spot where the wear was taking place. Let me know if you find out anything else. Thanks

  6. #6
    Senior Member droppixel's Avatar
    Join Date
    Apr 2011
    Location
    Plano, IL
    Posts
    1,611
    Post Thanks / Like

    Default

    Forgot from Jim's post on these he said:

    Mod settings, depending on how you want to look at it, either Martin has the incorrect DL specs listed and these are right on the money or they have the correct DL specs listed and the bow draws a 1/2" long. With the cable on the standard post and the mod set on the longest setting which is #5, the bow drew to an exact 31" AMO, on the #1 mod setting the bow drew to an exact 27" AMO. Either way, the bow set up on the standard post will draw from 27-31" in 1/2" increments and will be dead on AMO for each setting, using the draw stop you can fine tune the DL up a good bit or down just a little. Any way you look at it, the average sized archer will be able to get his exact DL dialed in. Because of time constraints, I didn't take the time to move the cable to the other 2 available posts, you can look back at the Pantera specs and get a pretty good idea where this bow will go to using the other posts.
    So that would you at 2-2.5 depending how you look at it and set your stop.
    2014 Lithium :: 2007 Cheetah :: Jaguar Take-down
    REAL AVID Field Staff / Bucks and Beards Scents Field Staff

  7. #7
    Senior Member wscywabbit's Avatar
    Join Date
    Nov 2008
    Location
    Sultan, WA
    Posts
    1,567
    Post Thanks / Like

    Default

    In their specs, the draw lengths they give take into consideration the range of movement given by the draw stop as well as changing the posts for draw weight. From the #1 peg to the #3 peg unless I'm mistaken is about 1" of movement shorter... and I'm not sure how much movement you'll get going all the way to then of the + or the -.
    In God and guns we trust;
    • One nation, under God, indivisible, with liberty and justice for all.
    • A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.


    2011 Onza 3: 70#, 28.25 draw (AMO), 384 gr arrow, 288 fps
    2005 Saber: 70#, same arrow, 250 fps

  8. #8
    Junior Member
    Join Date
    Apr 2012
    Posts
    9
    Post Thanks / Like

    Default

    I have it at a 2 right now with the stop about in the middle. Just have to wait on my Y cable to show up. I don't think it will rub now. Thanks for the info.

  9. #9
    Junior Member
    Join Date
    Apr 2012
    Posts
    9
    Post Thanks / Like

    Default

    Need more help. I shot about a hundred arrows through the bow with the new y cable on it. Where the string is hitting the axle it has already cut through the serving. I can't change the draw stop or I don't get the break over needed on the cam for any let off. I cant figure out why the serving is getting cut on the axcel that has no sharp edges. What help can you give me?

  10. #10
    Senior Member droppixel's Avatar
    Join Date
    Apr 2011
    Location
    Plano, IL
    Posts
    1,611
    Post Thanks / Like

    Default

    Sounds like you might be over-rotating it. Have you checked the module itself? If you say the cable is touching the axle, that sounds like a problem in itself. Does the draw length feel good with the setting you have the module in or do you think you could work with it a little bit more?

    There is still a lot about this cam that we don't know yet, so hopefully it will come in time.
    2014 Lithium :: 2007 Cheetah :: Jaguar Take-down
    REAL AVID Field Staff / Bucks and Beards Scents Field Staff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •