Results 1 to 5 of 5

Thread: Nitro cam rubbing against limb and QAD Ultra Rest problems - Please help!!

  1. #1
    Member deserthuntr's Avatar
    Join Date
    Jun 2012
    Location
    Bethlehem, South Africa
    Posts
    91
    Post Thanks / Like

    Default Nitro cam rubbing against limb and QAD Ultra Rest problems - Please help!!

    Hi Everyone. Have been shooting my new Onza 3 and am really enjoying it. But I have a few problems. Yesterday I noticed the top cam rubbing against the limb! How can I fix this? I am in Africa and don't have time to send my bow to the dealer as I have a hunt in 2 weeks time! I have a press and a lot of tools, how do I fix this?

    I also have a lot of fletch contact on my QAD ultra rest, anyone have any ideas on how to get better fletch clearance please? Can I set the spring tension? Or should I get a Trophy Taker? My nocking point is about an 1/8" high. Any help will be appreciated! Thanks guys.

  2. #2
    Senior Member Speedykills's Avatar
    Join Date
    Feb 2011
    Location
    Eastern Oklahoma
    Posts
    991
    Post Thanks / Like

    Default

    Could be excessive cam lean or weak limbs,you might want to double check specs make sure everything is right.
    As far as qad rest goes i just installed one on bengal no problems.Might want to check tension,usually if lines are even you good to go.I would shoot through paper to see if you off any.Are you getting contact on one vane or both!I take it youre shooting cock vane up!If your getting contact on one vane move rest in that direction to see if it clears.

  3. #3
    Member deserthuntr's Avatar
    Join Date
    Jun 2012
    Location
    Bethlehem, South Africa
    Posts
    91
    Post Thanks / Like

    Default

    Quote Originally Posted by Speedykills View Post
    Could be excessive cam lean or weak limbs,you might want to double check specs make sure everything is right.
    As far as qad rest goes i just installed one on bengal no problems.Might want to check tension,usually if lines are even you good to go.I would shoot through paper to see if you off any.Are you getting contact on one vane or both!I take it youre shooting cock vane up!If your getting contact on one vane move rest in that direction to see if it clears.
    Yes I shoot cock vane up, is that right? I get contact on both the other fletches!

  4. #4
    Senior Member Speedykills's Avatar
    Join Date
    Feb 2011
    Location
    Eastern Oklahoma
    Posts
    991
    Post Thanks / Like

    Default

    To me it sounds like your timing isnt right and or your nock point height needs adjusting.I say paper tune it to see whats it's doing and readjust the drop cord.If your using the little football it might have slipped...I use the football but it is nice and tight.....Also might have some string and cable stretch going on.
    Yes cock vane up is right.

  5. #5
    Member
    Join Date
    Sep 2011
    Location
    western ny
    Posts
    45
    Post Thanks / Like

    Default

    I have had same problem with my 2011 onza and 2012 cougarfc. You need new cams, the bushing are not perfectly square. talk to martin cs, tell them situation, they can mail u cams.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •