Results 1 to 3 of 3

Thread: Razor X Riser Questions

  1. #1
    Junior Member
    Join Date
    Feb 2012
    Location
    Tigard, Oregon
    Posts
    4
    Post Thanks / Like

    Default Razor X Riser Questions

    I have a 2004 Martin Razor X riser with Nitrous Cam B and a Shoot Through System and Elite Limbs. When I screw in the limb bolts all the way in, there is about 1/2" difference in the tiller measurement. The top measures 7-1/2" and the bottom measures 8". Also, I noticed that when I screwed in the top limb bolt, both the washer and bolt turn together. The bottom limb bolt turns while the washer remains stationary.

    Are these normal behaviors or should I be worried about the tiller difference and limb bolt turning with the washer.

    Thank you,

  2. #2
    Senior Member elkslayer4x5's Avatar
    Join Date
    Mar 2008
    Location
    Lane County, Oregon
    Posts
    2,927
    Post Thanks / Like

    Default

    I would check to see if something is under the bottom limb, a twig, or small rock, seems like something is holding it out there, the washer turning with the bolt is'nt anything to worry about, just a little metal bind, if you tried to hold the washer in place with channel-locks, the bolt would move freely.
    To check on the bottom limb ( or top ) back out the limb bolts until you can see the end of the limb bolt at the edge of the barrel nut, at this point the limbs should be slack enough for you to remove the string. But take a photo before you do, so that you'll know how to route the string when you restring the bow. Remove the cables, back the limb bolt all the way out and see whats going on under the limbs. When you've fixed the problem, reverse the procedure and re measure tiller. If I've led you astray, I'm sure that Barry or some of the other old guys will let us know.
    http://eastoutfitter.tripod.com/index.html
    http://www.cascadianbowmen.org/
    Martin 06 Slayer, Nitrous C, shoot thru, 63lb, Quiktune 3000, HAA OL 5519, Beman ICS Hunter
    Martin 06 Slayer, Nitrous C, Shoot thru, 55lb, Quiktune 3000, HHA OL 5519 2X, Easton A/C/C
    Ben Pearson 1968 'Cougar' 62" 45#s @ 28" recurve, parallel shaft POC, Zwickey 'Eskimo' 2 blade

  3. #3
    Senior Member
    Join Date
    Dec 2008
    Location
    Port Washington, Ohio
    Posts
    543
    Post Thanks / Like

    Default

    Could be the limb alignment studs are missing from one end also. If you look at the point where the limb leaves the limb pocket, you should see something that resembles a half of a silver ball bearing, there should be 2 of these at the end of each limb pocket. If these are missing from one of the pockets it would cause the difference in tiller that you are seeing.

    Advantage Custom Strings

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •