Results 1 to 3 of 3

Thread: Nother Question

Hybrid View

  1. #1
    Junior Member valkyriemc's Avatar
    Join Date
    Sep 2012
    Location
    NE Florida
    Posts
    6
    Post Thanks / Like

    Default Nother Question

    My used Alien, when drawn to the stop appears that the top control cable, top limb, does not stay in the narrow groove at the very end (where it narrows up)- that it should ride in. Then as the string is let down it rides back into the grove as it should. The string is now abraded at that spot. Bottom is fine. I can post pics later, but any thoughts so far?? TIA
    Rytera Alien X, QC Ranger single pin, Anchor Sight, Drop zone, BSting, Stan Quatro Shootoff, 250 Maximas' 27"
    Mathews Switchback '70lbs.

  2. #2
    Senior Member Ehunter's Avatar
    Join Date
    Mar 2010
    Location
    Southeast Kansas
    Posts
    1,770
    Post Thanks / Like

    Default

    If you could post a pic of what's going on, it would really help, but from your description, it sounds like you might need to smooth out the edge of the module. A few of them came with a sharper edge than they should have, and some fine sandpaper or a fine file can smooth the edge out nicely. Doesn't really need to be rounded, just make sure there's no sharp edge left.
    I would suggest posting a pic before trying this, as that way we can see EXACTLY where you are talking about, and make sure it's not something else. No need to sand on something that isn't a problem.
    2008 Moab 70# The deer killing bow
    2008/12 Firecat 60#--- 2010 Warthog 70#
    2009 Warthog 70#---2009-10-12? Warthog Frankenbow with Nitrous B
    2010 Strother SR-71 65# & 2012 Strother Rush 65#
    2012 Strother SX Rush 60# & 2011 Strother Infinity 70#
    BSD strings and cables

    Yeah, I know I'm grumpy and opinionated.

  3. #3
    Junior Member valkyriemc's Avatar
    Join Date
    Sep 2012
    Location
    NE Florida
    Posts
    6
    Post Thanks / Like

    Default More on my Alien X

    Local shop replaced the current string with my new back up due to wear from the modules (top), the draw stop was not set correctly causing over rotation of the modules and the string to "derail" slightly (top) on the module edge. Shop said time was good- but they looked at it at rest. But I know even as a new owner that timing is checked at full draw. Shop didn't have a draw board to check it so I rigged up a setup at home and it was obviously off. I think I have it really close now, but I'll check it again after more shooting. Only have shot it 30 some arrows. Nice accuracy @30 yards, banging some nocks-ouch. Anyway next issue somewhat common(?) to the X is noise. So I sold the Mathews SB, picked up speed but now face lotta noise. Searching through posts here and on A/T for a cure, seen mutiple possible causes, but anyone having fixed this issue on an Alien pls advise. Could send to Joel @ Martin but hoping to work through it myself... TIA!
    Rytera Alien X, QC Ranger single pin, Anchor Sight, Drop zone, BSting, Stan Quatro Shootoff, 250 Maximas' 27"
    Mathews Switchback '70lbs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •