Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Loud click from lower cam?

  1. #1
    Senior Member
    Join Date
    Apr 2011
    Location
    gerrardstown, wv
    Posts
    114
    Post Thanks / Like

    Default Loud click from lower cam?

    this summer I started noticing a slight click comming from my lower cam area when i start to draw. It's a 2011 exile with the acutrack cam. I thought that it was from the plastic modules. I've tried different modules, filing down the little burrs from where they were molded, rubber O rings on the module screws, oil, wax on the module and on the string posts, and tightening and loosening the srews. nothing seems to get rid on the noise. I've had the limbs replaced last year due to a splinter. the riser was replaced last summer to accomodate a lower string stop and the TRG/SOS conversion to the rod and cable slide. the click occurs just after the lower cam starts into its rotation and It's prettly loud when you have a whitetail 10 yards away on a dead still morning. anyone else have this problem and get rid of it. It's starting to really get to me....
    2011 Exile/01 Panther
    Rage/Muzzy
    TruGlo
    Easton Arrows
    Blazer Vanes

  2. #2
    Senior Member droppixel's Avatar
    Join Date
    Apr 2011
    Location
    Plano, IL
    Posts
    1,618
    Post Thanks / Like

    Default

    Had some noises with my Cheetah, check all the hardware and make sure it is tight. The source of mine actually was the cable rod screws where just a little loose allow the rod to move just a hair. See if that works for you - some of the other guys will chime in once they see.
    2014 Lithium :: 2007 Cheetah :: Jaguar Take-down
    REAL AVID Field Staff / Bucks and Beards Scents Field Staff

  3. #3
    Senior Member
    Join Date
    Apr 2011
    Location
    gerrardstown, wv
    Posts
    114
    Post Thanks / Like

    Default

    Actually had to have the cable rod screws replaced too because the holes were stripped out. no change. the only thing that temporarilly remedies it is if i draw the bow just enough to make it click and let it back down. the next time I draw it, it doesn't click as long as it's like no longer than an hour later. Then i have to do this all over again.
    2011 Exile/01 Panther
    Rage/Muzzy
    TruGlo
    Easton Arrows
    Blazer Vanes

  4. #4
    Senior Member droppixel's Avatar
    Join Date
    Apr 2011
    Location
    Plano, IL
    Posts
    1,618
    Post Thanks / Like

    Default

    Everything is tight and the limbs are fully seated in the RotoCups? Do you have access to a draw board or someone that can watch/listen as you draw to find out where the exact point is when the click happens? Might help you be able to narrow it down a little. I don't know enough to fully diagnose but bearings or axles could possibly be the spot? anyone?
    2014 Lithium :: 2007 Cheetah :: Jaguar Take-down
    REAL AVID Field Staff / Bucks and Beards Scents Field Staff

  5. #5
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,545
    Post Thanks / Like

    Default

    I've had a similar noise in several bows over the years and it was never the cam. There are two pads between the limb and roto-cup. They need some grease on their surfaces. You have to remove the limbs to do so. What happens is that when draw the limb flexes and moves a bit. Without proper lubrication there is a dry spot that can cause a click or creaking noise as the bow is drawn. My Alien Z does it, but being as it's not a hunting bow I don't worry about it.

    I hope this is what your problem is. Often times the hardest part is tracking down the noise.
    If You're Not Living on the Edge You're Taking Up Too Much Space
    Martin Gold Plus Staff Shooter
    Alien Mafia
    PSAA Life member, UBP Life member
    PADI AOW Diver

  6. #6
    Senior Member TEN RING's Avatar
    Join Date
    Dec 2011
    Location
    western PA
    Posts
    843
    Post Thanks / Like

    Default

    Quote Originally Posted by bfisher View Post
    I've had a similar noise in several bows over the years and it was never the cam. There are two pads between the limb and roto-cup. They need some grease on their surfaces. You have to remove the limbs to do so. What happens is that when draw the limb flexes and moves a bit. Without proper lubrication there is a dry spot that can cause a click or creaking noise as the bow is drawn. My Alien Z does it, but being as it's not a hunting bow I don't worry about it.

    I hope this is what your problem is. Often times the hardest part is tracking down the noise.
    My firecat was doing that I just sprayed some lithim grease in the roto cup no more noise
    MARTIN BENGAL
    THE NEED FOR SPEED
    WALMART PRO STAFF SHOOTER

  7. #7
    Senior Member
    Join Date
    Apr 2011
    Location
    gerrardstown, wv
    Posts
    114
    Post Thanks / Like

    Default

    I think I've done just about everything i could do to the cam with no results. never thought about the roto cup. I will try and see if i can get some oil to creep under there and get some results. don't wanna take the limb off if i don't have too. really sounds like it's at the cam but it could definetly resinate down the limb if it is the rotocup pads. had my wife listen to it while i pulled the string and she agreed to the cam area. I'll give this a try in the roto cup area.
    Last edited by wick; 12-21-2012 at 10:28 PM.
    2011 Exile/01 Panther
    Rage/Muzzy
    TruGlo
    Easton Arrows
    Blazer Vanes

  8. #8
    Senior Member
    Join Date
    Apr 2011
    Location
    gerrardstown, wv
    Posts
    114
    Post Thanks / Like

    Default

    You guys rock! that noise was driving me crazy. the lightest oil i had on hand at the house was some zebco reel oil so i put a dab right around the little pads that touch the limb on the rotocup and put a beed around the side guids on the cup too. pulled it back and it clicked once. took it outside and shot it about 6 times and sat it down this morning. just picked it up and went to draw it and it didn't even make a sound. Awsome! I swear it sounded like it was at the cam. Just wish I would have written this post in sept. everyone I talked to around here said it was the module. thanks.
    2011 Exile/01 Panther
    Rage/Muzzy
    TruGlo
    Easton Arrows
    Blazer Vanes

  9. #9
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,545
    Post Thanks / Like

    Default

    Quote Originally Posted by wick View Post
    You guys rock! that noise was driving me crazy. the lightest oil i had on hand at the house was some zebco reel oil so i put a dab right around the little pads that touch the limb on the rotocup and put a beed around the side guids on the cup too. pulled it back and it clicked once. took it outside and shot it about 6 times and sat it down this morning. just picked it up and went to draw it and it didn't even make a sound. Awsome! I swear it sounded like it was at the cam. Just wish I would have written this post in sept. everyone I talked to around here said it was the module. thanks.
    Let's hope it stays quiet.
    If You're Not Living on the Edge You're Taking Up Too Much Space
    Martin Gold Plus Staff Shooter
    Alien Mafia
    PSAA Life member, UBP Life member
    PADI AOW Diver

  10. #10
    Senior Member
    Join Date
    Apr 2011
    Location
    gerrardstown, wv
    Posts
    114
    Post Thanks / Like

    Default

    Just got back in from my treestand. Don't know why with it as windy as it is right now in West by god Virginia. 40 mph gusts today. but the temp says 30 degrees and even with the temp being low...no noise when i draw the bow. hopefully it does stay quiet but at least i know where it was comming from. never would have guessed the cup. Thanks again.
    2011 Exile/01 Panther
    Rage/Muzzy
    TruGlo
    Easton Arrows
    Blazer Vanes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •