Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Need Help ASAP

  1. #11
    Senior Member WildWilt15's Avatar
    Join Date
    Mar 2012
    Location
    livingston county michigan
    Posts
    542
    Post Thanks / Like

    Default

    Quote Originally Posted by Arrow Splitter View Post
    I'm curious as to why it is shooting like that. I have Nitro cams on my Firecat, and with no problems. They have been maintenance free, and I've shot my Firecat out to 60 yards. Maybe your rest isn't in quite the right place?? Do your cams not stay in time?

    A.S
    i checked that and they were in time when i first got it and they seemed just slightly off when i checked today not enough to really make any difference at all I will be taking it up to my local dealer tomorrow. which i hate to do because the guy is kind of an arrogant j*****s and i have had nothing but bad experiences in the past with him. Worse case scenario it goes back to martin and i have to pick a bow up to use as a hopefully temporary replacement.
    Martin x-200 unsure of year
    2011 Mathews z7magnum
    2012 Mathews z7magnum
    2014 Mathews ChillR (on order)

  2. #12
    Super Moderator Arrow Splitter's Avatar
    Join Date
    Oct 2010
    Location
    Gilmanton, NH, United States
    Posts
    3,562
    Post Thanks / Like

    Default

    If they do keep changing, it might be the string and cables. If the center shot is correct, the bow is in spec, the vanes aren't hitting anything, and your form is good, then I don't know what it is at this point.

    A.S
    2011 Martin Firecat 400/NAP Apache Dropaway/Truglo Xtreme Sight/Custom 8" Stabilizer/Victory V6 Arrows
    2007 Martin Jaguar /Trophy Taker Dropaway/Extreme Sight/Custom 21" Stabilizer/Victory V6 Arrows
    Bow String Depot, Custom String Builders email us @ bowstringdepot@gmail.com

  3. #13
    Senior Member wscywabbit's Avatar
    Join Date
    Nov 2008
    Location
    Sultan, WA
    Posts
    1,575
    Post Thanks / Like

    Default

    Quote Originally Posted by Arrow Splitter View Post
    If they do keep changing, it might be the string and cables. If the center shot is correct, the bow is in spec, the vanes aren't hitting anything, and your form is good, then I don't know what it is at this point.
    A.S
    X2. It sounds as if something is moving on you. Especially since you said it seemed to get worse as you were shooting. I would take a step back, measure your specs and if they're good, start at the beginning and tune it again. I have the same cams on my Onza, and I've yet to have them come untuned or unset once I was done... But I have had accessories come loose and drive me nuts before.

    Once you get it all set again, go through one screw at a time and set them with blue loctite... it won't happen again. Good luck!
    In God and guns we trust;
    • One nation, under God, indivisible, with liberty and justice for all.
    • A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.


    2011 Onza 3: 70#, 28.25 draw (AMO), 384 gr arrow, 288 fps
    2005 Saber: 70#, same arrow, 250 fps

  4. #14
    Senior Member Ehunter's Avatar
    Join Date
    Mar 2010
    Location
    Southeast Kansas
    Posts
    1,772
    Post Thanks / Like

    Default

    If you have to, in a pinch, you can always mount the sight on the inside of the riser to get the extra left adjustment you need. I do agree with everyone else though, something's just not right. I've had several bows with the roller guard, and while I'm not a big fan of them, they haven't caused me any real problems. They do induce a little lean, but I've had no problem keeping a bow in tune with them, or the Nitro cams. Even though your arrows should be the right spine, have you tried dropping the draw weight, or shooting a stiffer arrow just to see what happens? Also might try relaxing the bow, then checking the cam bearings and axles. Got a Cat cam back from being dipped, and was having problems with getting tuned. Found out the guy that dipped it had not protected the bearing, and it was fouled up beyond repair. It was causing the bow to shoot erratically as you are describing.
    2008 Moab 70# The deer killing bow
    2008/12 Firecat 60#--- 2010 Warthog 70#
    2009 Warthog 70#---2009-10-12? Warthog Frankenbow with Nitrous B
    2010 Strother SR-71 65# & 2012 Strother Rush 65#
    2012 Strother SX Rush 60# & 2011 Strother Infinity 70#
    BSD strings and cables

    Yeah, I know I'm grumpy and opinionated.

  5. #15
    Banned
    Join Date
    Sep 2011
    Location
    Brookhaven, Ms
    Posts
    350
    Post Thanks / Like

    Default

    all the bad news on the 2013 ryteras is starting to scare me ..... wait where is my bow....

  6. #16
    Senior Member Tosi's Avatar
    Join Date
    Oct 2011
    Location
    Flagstaff, AZ/AZ High Country 7000 feet
    Posts
    522
    Post Thanks / Like

    Default

    Something is wrong. I would bet it's the Cable, Sting or drop. You may won't to give them a twist to see what happens. Give them a twist, set the center shot and shoot paper to see were that gets' you. Check your drop also. Had and issue with the fork on one of my drop away rests that was similar to what you're experiencing is. The fork was bent slightly and causes the issue
    Ranger 6
    2011 Fire Cat 400 (Custom)
    2005 Martin SlayR
    2012 Mathews z7 Magnum
    2014 Mathews Creed
    2001 PSE Excellerator

  7. #17
    Senior Member WildWilt15's Avatar
    Join Date
    Mar 2012
    Location
    livingston county michigan
    Posts
    542
    Post Thanks / Like

    Default

    At the shot the string misses the string stop to the right now. I'll give an update when I got the the shop I have a back up bow on the way through km archery hut an alien z with the acu track cam I will get this resolved though.
    Martin x-200 unsure of year
    2011 Mathews z7magnum
    2012 Mathews z7magnum
    2014 Mathews ChillR (on order)

  8. #18
    Sonny Thomas
    Guest

    Default Need Help ASAP

    Don't mean to beat it into the ground, but like I've said in other threads, correctly timed I've found nock setting is near zero, usually 1/16" high. And even today 1/8" high is acceptable - not me, but just saying.

  9. #19
    Senior Member Tosi's Avatar
    Join Date
    Oct 2011
    Location
    Flagstaff, AZ/AZ High Country 7000 feet
    Posts
    522
    Post Thanks / Like

    Default

    Quote Originally Posted by WildWilt15 View Post
    At the shot the string misses the string stop to the right now. I'll give an update when I got the the shop I have a back up bow on the way through km archery hut an alien z with the acu track cam I will get this resolved though.
    WOW! Know that issue with the string stop. I had the same issue on my Fire Cat 400, missing the string stop. Change out string stop with a Mathews string stop, replaced cables/string with Stone Mt Titanium 8190 String w/452x Cables. Also re-set the draw stop and it was shooting lights out. It was shooting a 420g arrow at 288fps. Hope ya get it fixed, let us know how that Alien-Z with Acu-Track works for ya. Send Pics.
    Ranger 6
    2011 Fire Cat 400 (Custom)
    2005 Martin SlayR
    2012 Mathews z7 Magnum
    2014 Mathews Creed
    2001 PSE Excellerator

  10. #20
    Senior Member WildWilt15's Avatar
    Join Date
    Mar 2012
    Location
    livingston county michigan
    Posts
    542
    Post Thanks / Like

    Default

    Update. Bow is going in I picked up a Bengal pro instead of the alien z because I figured it would be more ideal for hunting, i set it up today. Nice little bow for sure. Dealer said there was definitely something wrong with the cams limbs or possibly the axles won't know for sure until we get it back in a few weeks.
    Martin x-200 unsure of year
    2011 Mathews z7magnum
    2012 Mathews z7magnum
    2014 Mathews ChillR (on order)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •