Results 1 to 5 of 5

Thread: Broken Bow?

  1. #1
    Unregistered
    Guest

    Default Broken Bow?

    I Have A Martin Panther Compound Bow. I Went To Pull It Pack And It Pops Sounds Like Its Coming From The Cams And It's Loud It Has Never Done This Before. This Ouccurs When I Have My Bow At Half Draw When I Hear The Poping Noise. Then All Of A Sudden It Pulls Back Extremely Fast It Feels Like Im Only Pulling 1lb. The Limbs Are Maked Out And Can't Find No Obvious Signs Of Damage Or Cracking On Limbs, Or Cams. A Couple Of Guys Who Shoot Pro Looked At It At The Match And Couldn't Find The Cause Either. Anyone Else Have Any Ideas?

  2. #2
    dbd870
    Guest

    Default

    I wouldn't draw it again, there is definitely a problem. Get it to a pro shop and let them look it over.

  3. #3
    flytier17
    Guest

    Default

    DOes it do this every time the bow is drawn? Don't draw it again to check, just wondering if you already know.

    Check the A2A and BH. If they are fine, then it is not the String most likely. Check the Mods screws and the Mods to see if theyare loose. Makesure the string groove in the cams is clear.

    Check the rest. If it is a dropaway, most likely it is operated by a cord. If it loosened, or tightened, the rest could be triggering prematurely or something.. Check the cable slide to make sure it is not sticking.

  4. #4
    Senior Member
    Join Date
    Nov 2007
    Location
    Germany
    Posts
    2,007
    Post Thanks / Like

    Default

    I had a popping sound for some times, too. I came from the cable that was pushed too far away from the cam. When drawing the bow the cable jumped over from the cam to the mod. I wonder when it stopped, just ignored it for some time and now there is no problem at all...

    But better check everything as alec said or go to a pro shop and have them take a look on it.
    (2) Hoyt PCEXL

  5. #5
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,544
    Post Thanks / Like

    Default

    You guys don't give me much room. Just about got things covered. I was thinking it's either a loose module or maybe too much offset to the cable rod. If the cable rod is ajussted too far out then it's possible that when drawing the bow he cable is trying to roll itself off the module, but instead is just "popping" itself into the module groove at the last minute.

    Or, as stated about the draw, and this can be ugly, the cable is actually rolloing off the module and is instead sliging down along side it. As I said,----UGLY. I think I would be getting it to a shop----again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •