Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Dropaway rests not working

  1. #11
    HungarianHammer
    Guest

    Default

    Quote Originally Posted by bfisher View Post
    It's possible you have gotten one of only two risers that are maybe working loose at that joint. It's a shame, but these things can happen. And it doesn't happen often, but I've seen one-piece risers snap. I once had one do this--many many years ago. I'm sure Martin will take a good look at it and do what is right for you, the customer.

    By any chance do you have the CCS on your bow? Reason I ask is that I have an '09 Moab with it and it had a slight metallic sound to it. I never did track down the actual source, but added some Bow Jacks to the limbs and STS rod and it helped a great deal. I'm not 100% sold on the CCS yet, but I'm not fond of cable rods either since having owned a couple X system bows.

    I do have noise from my rest (Trapdoor) which is going to be replaced very soon. Just can't make up my mind whether I want to put on a TT Spring Steel or my GKF Infiniti drop away. I've used them both before and know what to expect. Just can't make up my mind yet.
    BFisher, i took my 09 cheetah into the pro shop and the tec shimmed the CCS.problem solved.... i had that sound and it was caused by the rollers rapidly shifting to one side. Not sure if i mentioned that before

  2. #12
    HungarianHammer
    Guest

    Default

    Quote Originally Posted by Hookedonbows View Post
    Sorry Barry, I don't know how to include your quote. And yes I have both the CCS and the STS and I suppose it could be the CCS making the noise as it is really hard to pin point exactly where it is coming from. I just can't see that making a metalic sound but then anything is posible.
    When I seen the joint movement I took for granted that it was coming from there, as the metal to metal contact of the two pieces would be the more logical source of the noise.
    Thanks for your input.
    Check the CCS and push the rollers to one side. if they move take it to the pro shop and they can use new spacers to fill the gap. Did it to mine and it worked to get rid of the metallic sound. hope this is your prob and not the riser.

  3. #13
    Junior Member
    Join Date
    Jan 2009
    Location
    Buckley, Wa
    Posts
    19
    Post Thanks / Like

    Default

    i have the 09 bengal with STS and CCS installed, works great but there is a metal sound i'm hearing also that won't go away!. I use the G5 Expert 2 drop away with no fletching issues and its SUPER QUIET!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •