Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: 2009 Warthog's Serious C.A.T. Mod problem

  1. #1
    www.coloradotactical.com
    Guest

    Exclamation 2009 Warthog's Serious C.A.T. Mod problem

    So, rather than attack the problem at hand, someone at Martin made my post disappear. PLEASE MAKE MY MOD PROBLEM DISAPPEAR! Now there is a novel concept...

    Whomever deleted my post, please inform me why you deleted it, other than you realize there is a major problem, and you don't want anyone to know about it...

    please advise what you are doing at a factory level to fix this issue you apparently don't want anyone to know about.
    Attached Images Attached Images

  2. #2
    flytier17
    Guest

    Default

    I can't seem to find it either. I looked up the record of your posts, and it shows only 2 threads started by you. The third is missing.

    I'm not sure how a thread gets deleted here. I don't think its a tool the mods have either.

    I saw nothing wrong with your thread. You approached the topic with tact, and I saw nothing offensive about any of the posts on the thread either.

    I don't know why someone would have deleted it for the reasons you implied either though. There have been many more regarding Firecat limbs, and other factory screwups like wrong limbs shipped etc... I don't understand why this would be singled out like that, especially as it was not an offensive thread.

    This is probably the last time I'll be here for a week or so, so unfortyunately, I cna't help much. Maybe another moderator can assist you further.

    All the best with your problem, I hope it is resolved to your satisfaction.


    Alec

  3. #3
    www.coloradotactical.com
    Guest

    Thumbs up Thanks Alec.

    I appreciate your input. not sure If I told you but I chrono'd @ 297-302 spread, I am anxious to see what happens when I crank to 70lbs and also when I put the new cable guard to move the cables out more so they wont rub. I don't think it is a good fix, but it will keep me shooting...

    Thanks again for your help and comments.

  4. #4
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,588
    Post Thanks / Like

    Default

    I have to agree with Alec. In no way did I read anything so derogatory as to deserve the thread being deleted. In fact, I found it more informative than anything.

    I'm sorry that you're having such a problem with the Hog. I have a 2008 FireCat with the same cams and I see a little rubbing on the bottom cam, but not severe enough to warrant compaining. In fact, I'm still shooting the same cables/string and see little to no fraying of the serving at the cam, even after about 5000 shots or so.

    I don't think I'm in a position to be of any help to you, but I do hope it gets resolved, for your sake and the company's.
    If You're Not Living on the Edge You're Taking Up Too Much Space
    Martin Gold Plus Staff Shooter
    Alien Mafia
    PSAA Life member, UBP Life member
    PADI AOW Diver

  5. #5
    Senior Member
    Join Date
    May 2009
    Location
    Colorado
    Posts
    1,699
    Post Thanks / Like

    Default

    I posted the thread about my FireCat being shipped with the wrong limbs on it and find it rather curious that there has been NO replys. Denial ? ? ?
    I really wasn't upset about the whole thing, even tho it puts me a couple weeks behind on practice with the new bow before the hunting seasons open, however when I contacted Martin about it they offered no apoligies and didn't really express any concern at all.

  6. #6
    www.coloradotactical.com
    Guest

    Exclamation Martin's Customer service

    I know this forum is for help from other users. I guess I was hoping someone that actually worked @ the factory was on here as well and could be the full blown expert.

    I have been having issues, and I have received some pretty good insight from the forum, especially Alec up in Canada.

    I am not sure why no one commented on your post regarding the wrong limbs, had I checked it out, I would have commented about why I am still shooting a Warthog... About 25 years ago (give or take 5 years) My dad, brother and I (all shooting martin's) were out back shooting into our Lint Bail and we heard the most amazingly loud crack/explosion from my dad's Martin Warthog. Believe it or not, both limbs exploded as soon as he let the arrow fly. Apparently they are laminated or use to be anyway. I thought a bomb went off. Long story longer... We called martin, they apologized, sent us the address to ship to and within 3 weeks I was shooting my dad's brand new 1980's Martin warthog with absolutely no charges to us except shipping it back to them. Please keep in mind that this bow was old, used and not in mint condition by any stretch. After customer service like that...I have to stay loyal

    That being said...I am still annoyed about the CAT cam system that is rubbing my cables big time!

    I hope Martin took care of you and sent you all the right parts and peices the second time around?

  7. #7
    HungarianHammer
    Guest

    Default

    i had issues with my new 09 cheetah and matin was great at correcting the problem.......I too had my threads deleted, like all 20 of them....hmmmm ......I REALLY UNDERSTAND YOUR FRUSTRATONS ..Good luck

  8. #8
    www.coloradotactical.com
    Guest

    Exclamation I am curious about what problems you had

    can you elaborate on what issue you had? I am very curious as to why certain issues get deleted, yet I have this post that has not been deleted? I suspect they only check every so often.

    anyway, please let me know what issues you had, I am just curious.

    thanks!

  9. #9
    Senior Member
    Join Date
    May 2009
    Location
    Colorado
    Posts
    1,699
    Post Thanks / Like

    Default

    Quote Originally Posted by www.coloradotactical.com View Post
    I know this forum is for help from other users. I guess I was hoping someone that actually worked @ the factory was on here as well and could be the full blown expert.

    I have been having issues, and I have received some pretty good insight from the forum, especially Alec up in Canada.

    I am not sure why no one commented on your post regarding the wrong limbs, had I checked it out, I would have commented about why I am still shooting a Warthog... About 25 years ago (give or take 5 years) My dad, brother and I (all shooting martin's) were out back shooting into our Lint Bail and we heard the most amazingly loud crack/explosion from my dad's Martin Warthog. Believe it or not, both limbs exploded as soon as he let the arrow fly. Apparently they are laminated or use to be anyway. I thought a bomb went off. Long story longer... We called martin, they apologized, sent us the address to ship to and within 3 weeks I was shooting my dad's brand new 1980's Martin warthog with absolutely no charges to us except shipping it back to them. Please keep in mind that this bow was old, used and not in mint condition by any stretch. After customer service like that...I have to stay loyal

    That being said...I am still annoyed about the CAT cam system that is rubbing my cables big time!

    I hope Martin took care of you and sent you all the right parts and peices the second time around?
    I've been shooting Martin bows for 30 years or so and still own 4 Martins. Out of all of them I've had - only one has ever had any sort of problem and after a couple attempts at fixing it Martin just sent me a new bow (actually an updated version) at no cost to me. I still have and shoot it. Their customer service in the past has always been great so even tho I dont quite understand how a bow can get shipped out labeled as a 60#dw 30"dl when it pulls at 74# and has the standard modules on it - I'm positive that they will correct the issue and I will be very happy with it. The cable clearance issue is a concern to me also because of the C.A.T. cams and I will be watching them closely when I get the bow back and start shooting it. Martins service has always impressed me and I trust they will take care of this for all us CAT cam owners.

  10. #10
    dbd870
    Guest

    Default

    I noticed it was gone as well; I didn't see any reason to remove it either? I had a problem with idler on my 08 MOAB, Martin sent the parts in a timely fashion and it's up and running. It is still the best feeling bow (to me) I've ever owned and I really like it, however if someone at Martin pulled your thread they need to understand it just hurts their reputation with the shooting community; I'm very disappointed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •