Results 1 to 6 of 6

Thread: cable guard

  1. #1
    korkskru
    Guest

    Default cable guard

    bought a brand new saber, love it. but my cable guard is just to close to my fletching and rubs just ever so much. loosend the set screws and tried to turn it. its not budging. didnt know how to get it to move. i have all ready skinned it up. should i move my rest and sites over for clearance? a bit of help would be appreciated. my first martin, and will probably be a fan for a long time. thanks brian

  2. #2
    tood s
    Guest

    Default

    cable guards have grooves on the end that go into the riser. You have to pull it out of the riser then turn it to get the clearance that you need. Remmember not to turn it too far, just enough to clear your vanes

  3. #3
    korkskru
    Guest

    Default

    are they hammered in, this thing is super tight, trying to pull straight out. wont budge. i hope everything else stays this tight and has a snug fit. brian

  4. #4
    Senior Member alex's Avatar
    Join Date
    Nov 2008
    Location
    Bulgaria
    Posts
    1,366
    Post Thanks / Like

    Default

    On some models the cable rod is glued so don't use force.You'd better go to a pro-shop.
    2008 Martin MOAB - 45-60#, set at about 51-53# / 55#" Perfect Line" compound/ 55# Mongol horsebow/ 45# "Perfect Line" takedown recurve/ 45# Bearpaw Grizzly hunter recurve/ 55# Samick Longbow Cheetah ... and several homemade bows

  5. #5
    Coop
    Guest

    Default Hi,

    Are you sure you unscrewed the allen screws(2ea) enough, you can actually take them all the way out. Might try that.. my cable guard just about falls out when I loosen the allen screws, but, I have a Sceptor risor, so it might be different. If they glued it, than I wouldn't know how to rotate it and/or take it out. Kinda' defeats the purpose to adjust the cable guard if glued.

    Good luck to ya',
    Coop

  6. #6
    korkskru
    Guest

    Default

    fixed. put my ripcord on it. it gave me quite a bit more clearance. i had an nap easy tune, and wore the brushes out on it pretty bad, no more than i shot it. but its fixed, thanks all who offered advice. brian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •