Results 1 to 6 of 6

Thread: E-clip size

  1. #1
    warthog
    Guest

    Default E-clip size

    Does anyone know what size e-clip I need for the axle on my warthog?

    Just put my new limbs on and must have damaged the clip taking it off. After putting the bow back together and shooting I noticed a vibration at the top of the bow. Found that the e clip is loose to the point that it spins freely around the axle and comes off quite easily.

    I don't think the hardware store would appreciate me taking my bow in to try clips.

  2. #2
    Senior Member elkslayer4x5's Avatar
    Join Date
    Mar 2008
    Location
    Lane County, Oregon
    Posts
    2,813
    Post Thanks / Like

    Default

    "I don't think the hardware store would appreciate me taking my bow in to try clips. "
    Well, you couuld remove said loose E clip and take that into the hardware store.
    http://eastoutfitter.tripod.com/index.html
    http://www.cascadianbowmen.org/
    Martin 06 Slayer, Nitrous C, shoot thru, 63lb, Quiktune 3000, HAA OL 5519, Beman ICS Hunter
    Martin 06 Slayer, Nitrous C, Shoot thru, 55lb, Quiktune 3000, HHA OL 5519 2X, Easton A/C/C
    Ben Pearson 1968 'Cougar' 62" 45#s @ 28" recurve, parallel shaft POC, Zwickey 'Eskimo' 2 blade

  3. #3
    BadgerND
    Guest

    Default

    Years ago, I bought a little box that had about a dozen e-clips of each size. Cost about $3, and I still have 90% of them left.

  4. #4
    Senior Member
    Join Date
    Nov 2007
    Location
    Germany
    Posts
    2,014
    Post Thanks / Like

    Default

    You can get those e-clips boxes at many hardware stores or via online archery shops.
    (2) Hoyt PCEXL

  5. #5
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,595
    Post Thanks / Like

    Default

    Or youy could just squeeze ita little bit with a apir of pliers. I've done this and it works. Doesn't take much.
    If You're Not Living on the Edge You're Taking Up Too Much Space
    Martin Gold Plus Staff Shooter
    Alien Mafia
    PSAA Life member, UBP Life member
    PADI AOW Diver

  6. #6
    warthog
    Guest

    Default Good Thinkin'!

    Thanks Barry!!!!

    For some reason I was thinking that the clips were a spring steel and would have no memory, Put a little pressure on with my nocking pliers and problem solved.

    Tried many differnet sizes that never worked. Tightened up the original and problem solved. I guess if they had no memory the thing would still be as tight as ever.


    If this didn't work the clip was gonna get a string wax treatment which would have likely silenced the vibe for a while.

    Thanks to everyone for their suggestions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •