Results 1 to 6 of 6

Thread: 09 Martin bow problem

  1. #1
    mmasteve
    Guest

    Default 09 Martin bow problem

    i have an 09 Martin Moab i have had it for about a month shot it 2 or 3 times a week. i noticed that were the CCS pulls the string to the left its forcing it to rub on the idlerwheel at the top and eating into it. i took it to the shop were i purchesed it and when they talked to martin , martin told him they would send a new string, and 2010 idler wheel and that would fix the problem. that the 2010 wheel was bevelled around the edges and that would fix it. what do you guys think. if anyone has a 2010 and 09 model is there a difference in the wheel edges? and has anyone else had this problem?

  2. #2
    mmasteve
    Guest

    Default

    anyone please

  3. #3
    Member
    Join Date
    Feb 2010
    Location
    Tennessee
    Posts
    68
    Post Thanks / Like

    Default

    Is the idler wheel leaning to one side?

  4. #4
    mmasteve
    Guest

    Default

    no the guy at the bow shop said another guy with a cheeth with the ccs is having the same problem and martin wanted him to send his bow back.

  5. #5
    Dave308
    Guest

    Default

    You need to put some serving on it.

  6. #6
    mmasteve
    Guest

    Default

    the person with the same problem martin sent them a string with the serving and it eat into it and the string so they put a zebra string on it and it did the same so i will be interested to see what happens when they put a new idler wheel on mine. if the problem still isnt fixed im going to push the bow shop to refund my money on it and let me pay the difference to get a different bow.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •