Results 1 to 4 of 4

Thread: Heard a loud snaping sound......!!!

  1. #1
    Senior Member
    Join Date
    Nov 2009
    Posts
    108
    Post Thanks / Like

    Default Heard a loud snaping sound......!!!

    Hey Guys,
    Had my Martin Warthog out yesterday and after only three launches, I heard a loud snap when almost at full draw. I let the arrow fly and then inspected the limbs, but couldn't see a crack anywhere. I let a few more arrows fly down range and couldn't replicate the snap sound.....is there a way to see whether I've cracked another limb? Are all of the '09 limbs defective? Man, what a let down on a $700.00 + bow......
    ________
    digital vaporizers
    Last edited by baerman; 01-22-2011 at 03:42 PM.

  2. #2
    Senior Member
    Join Date
    Nov 2007
    Location
    Germany
    Posts
    2,008
    Post Thanks / Like

    Default

    Quote Originally Posted by baerman View Post
    Hey Guys,
    Are all of the '09 limbs defective? Man, what a let down on a $700.00 + bow......
    No. I owned a 2009 Warthog and used it around 3 months and had no problems with the limbs.
    if you have the chance get to a pro shop and let them disassamble your bow to check if the limbs are okay. There can be different reasons for a snapping sound to occur. The Roto-pockets could have been loose. The cables or string snapped in place, etc.

    An idea that just comes to my mind:
    Measure th ATA of the bow on both sides of the limb. There might be a little difference which is induced by the Cam design. if it is more than x/32" you have some bend in the limb which miht be caused by a crack.
    (2) Hoyt PCEXL

  3. #3
    danmcmanus
    Guest

    Default

    I've had 6 sets of 2009 limbs crack; 3 each on my 09 Warthog and my 09 Firecat. Every time, they talk about a new design......they know they have a limb problem.

  4. #4
    Senior Member
    Join Date
    May 2009
    Location
    Colorado
    Posts
    1,699
    Post Thanks / Like

    Default

    I've been shooting my 09 Firecat non-stop for a year and a half now with no problems at all.
    Also have an 09 Alien X that I shoot daily with no issues!
    Both bows are at 29"dl and 60# (just a touch under max) with 390gn arrows.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •