Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: martin warthog

  1. #11
    Member
    Join Date
    Jan 2010
    Posts
    53
    Post Thanks / Like

    Default

    Hey copterdoc,
    If that is true, then what is the correct IBO for the Warthog? Would seem to be slower than 350 fps. Is it normal proceedure to adjust a bow outside of normal set up in order to get a higher IBO speed? Just asking because it sure can be confusing.

  2. #12
    Senior Member
    Join Date
    Dec 2009
    Posts
    310
    Post Thanks / Like

    Default

    It'll do 340 at 80% let-off.

    You just have to take off the STS, and let the speed nocks do their thing.

    The whole idea behind that "optimum setting" thread, is to retard the cams enough, that you can set the modules to a shorter DL setting than #5.

    If you get past the #4 module setting, you get into the "hump", at the end of the draw cycle.

  3. #13
    Member
    Join Date
    Apr 2010
    Location
    columbus indiana
    Posts
    45
    Post Thanks / Like

    Unhappy

    thanks guys for all the info i took today to check all my string lengths and ata also went to the 29.5 setting from the 29 setting and shortened my stop so there was not let off and still no better. i was still only getting about 300 with my 300 grain arrows at 60 lbs. i guess i will have to spend the money to ship back to martin if they will do it again i just hate to spend the shipping to do it again but i will mark the cams good this time.

  4. #14
    Member
    Join Date
    Apr 2010
    Location
    columbus indiana
    Posts
    45
    Post Thanks / Like

    Default

    am i expecting to much to be looking for more speed?

  5. #15
    Senior Member
    Join Date
    Dec 2008
    Location
    Port Washington, Ohio
    Posts
    543
    Post Thanks / Like

    Default

    Quote Originally Posted by cridertj View Post
    am i expecting to much to be looking for more speed?
    No your not expecting too much, actually at 29/60 with a 300gr arrow you should be pulling about 320+/- with a loaded string, IF everything is setup correctly.

    Advantage Custom Strings

  6. #16
    Senior Member
    Join Date
    Dec 2009
    Posts
    310
    Post Thanks / Like

    Default

    At 29" of DL, with no let-off, you were only getting 300 F.P.S. with a 300 grain arrow, at 60#?

    Take the STS OFF of the bow, and see what happens.

  7. #17
    Member
    Join Date
    Apr 2010
    Location
    columbus indiana
    Posts
    45
    Post Thanks / Like

    Unhappy

    that's what i was thinking but cant seam to get there, i don't know but it may be the new limbs they put on them in early 2010 slowing things up i don't know? i have tried to remove the sts and have messed the end of it up with a pair of vice grips and a hammer and cant get it freed up , all set screws removed and had pro shop try it with no luck .love the bow but have had no luck in performance area and really frustrated with it . i mean martin didn't Even get it past 311 when i sent it to them .and sic then i have had really bad paper tunes to with bad left tears when paper tuning with different rest and different people trying it. I am thinking about getting a rytera nemeses next month for a target bow but am just a little leery of it. right now i wish i could just start with a new warthog that hasn't gave me as much trouble and rebuild my confidence but if i get the rytera that will be all i will be able to do for the next year or so.
    Last edited by cridertj; 01-23-2011 at 04:09 PM.

  8. #18
    Senior Member
    Join Date
    Dec 2009
    Posts
    310
    Post Thanks / Like

    Default

    Have you actually measured your bow's brace height, draw weight, draw length and your arrow weight?

    DON'T GUESS, OR BELIEVE ANYTHING FROM THE SPECS/CHARTS!

    Measure those things. Make sure they are all what you think they are.

    If you can't remove the STS, rotate it out of the way, so that the string doesn't hit it.

  9. #19
    Member
    Join Date
    Apr 2010
    Location
    columbus indiana
    Posts
    45
    Post Thanks / Like

    Default

    yes i went through and took string and cables off remeasured them re installed and checked brace and ata and still same results the sts is stuck right were it is me and pro shop has tried it move it and adjust it but just messing it up doing it .

  10. #20
    Senior Member
    Join Date
    Dec 2009
    Posts
    310
    Post Thanks / Like

    Default

    Quote Originally Posted by cridertj View Post
    yes i went through and took string and cables off remeasured them re installed and checked brace and ata and still same results the sts is stuck right were it is me and pro shop has tried it move it and adjust it but just messing it up doing it .
    I don't care about the ATA. You need to MEASURE the draw weight and draw length, as well as the brace height.

    The ATA barely matters.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •