Results 1 to 6 of 6

Thread: roller guard problem

  1. #1
    kennyf
    Guest

    Default roller guard problem

    i am new to this forum and wanted to ask a question
    i have a 2010 firect tr1 and when i draw my bow it seems like there is something catching in the roller guard i took it to the shop and they dis assembled it and checked it over and re assembled it putting some lube inside it. it got a little better but then started again. there is a noticable noise also. i plan on going back to the shop when i get a chance. just wondering if anyone had any suggestions?

  2. #2
    Senior Member
    Join Date
    Dec 2008
    Location
    Port Washington, Ohio
    Posts
    543
    Post Thanks / Like

    Default

    Could be a bad bearing in one of the rollers. Also make sure there is a small spacer between the 2 rollers so they don't touch.

    Advantage Custom Strings

  3. #3
    kennyf
    Guest

    Default

    i think that might be theproblem when i draw it the roller on the right is the one that makes the noise i think its rubbing on the other roller. im going to go to the shop tomarrow and see what they say. thanks for the input

  4. #4
    kennyf
    Guest

    Default

    had the guy at the shop look at it again he put alittle spacer in there problem solved!

  5. #5
    Senior Member
    Join Date
    Oct 2009
    Location
    michigan
    Posts
    510
    Post Thanks / Like

    Thumbs up rh stage 2

    I am guessin u should have got that spacer when u bought the bow or is it a extra >?

  6. #6
    Senior Member
    Join Date
    Dec 2008
    Location
    Port Washington, Ohio
    Posts
    543
    Post Thanks / Like

    Default

    There is supposed to be a thin spacer between them, either that one got past QC without it or someone else had it apart and didn't put it back in.

    Advantage Custom Strings

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •