Results 1 to 3 of 3

Thread: gggrrrrrrrrrrrrrrrrrrrrrits ha ppening again !

  1. #1
    Senior Member
    Join Date
    Oct 2009
    Location
    michigan
    Posts
    510
    Post Thanks / Like

    Thumbs up gggrrrrrrrrrrrrrrrrrrrrrits ha ppening again !

    well as nice as day as u can get came around today , and all i could think was pullin the bow out for a shoot , at the end of the season i felt it was screwin up a little and to no avail it is defiantly a prob , after about 15 min of frustration ,i started to check all the fasteners , before i got to the module screws i noticed one didnt look right , all said and done it was loose ,and apparently stripped in the cam , im sure this has happened to some of u all whats the best fix if any ? bummed again grrrrrrrrrrrrrr

  2. #2
    SonnyThomas
    Guest

    Default gggrrrrrrrrrrrrrrrrrrrrrits ha ppening again !

    One of two things, new cam or go to next larger size thread screw.

    I don't know what the problem is. I don't care what the problem is. BUT as much trouble as Martin has had somebody should have already been off their butts and got this screw problem solved and done away with.

    The whole just seems stupid. I mean, if you don't have the screws super tight they come loose. Too tight and you can't get them loose.

    On a 2008 Firecat I had to drill the screw out. Busted one allen wrench and rounded off another. The da__ allen hole too small, I replaced all the screws with screws from Pearson. No more problem.
    Last edited by SonnyThomas; 04-11-2011 at 07:20 AM.

  3. #3
    Senior Member
    Join Date
    Oct 2009
    Location
    michigan
    Posts
    510
    Post Thanks / Like

    Thumbs up rh stage 2

    hey sonny so u say i can get after market screws over size?, and retap them ?,I think my cam is plastic , not fer sure but the thread parts that came off the screw seemed pretty rubbery , thats pretty much how I got it back from martin, first time I ever checked for tightness , because it started shootin worse and worse , i had a good guess something was lose besides the operator, lol thats why i checked it , I kind of tom foolery rigged it fer now and accuracy seems to be back on track , My prob is I dont trust it now , those screws u mentioned sound like the trick , how do I go about getting some ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •