Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Martin Silencer TRG

  1. #1
    Member
    Join Date
    May 2011
    Location
    Maryland
    Posts
    33
    Post Thanks / Like

    Post Martin Silencer TRG

    My Issue is first the fiberglass rod was cracked when I got it from UPS the second issue it seems to be smacking the inner cable slide plus looks like its melting my strings

  2. #2
    Senior Member Simple Life's Avatar
    Join Date
    Jul 2010
    Location
    Up here
    Posts
    999
    Post Thanks / Like

    Default

    Welcome to the forum bricka,here is some links-

    First has the manual and how to adjust the TRG

    http://martinarchery.com/mtechforum/...ghlight=Manual

    And here is what some guys are using on the string.

    http://martinarchery.com/mtechforum/...scorpion+venom

    SL
    2011 Firecat 400
    2013 PSE Drive
    2012 PSE Brute X

  3. #3
    Senior Member
    Join Date
    Jan 2011
    Location
    Tacoma, WA
    Posts
    130
    Post Thanks / Like

    Default

    Quote Originally Posted by bricka View Post
    My Issue is first the fiberglass rod was cracked when I got it from UPS the second issue it seems to be smacking the inner cable slide plus looks like its melting my strings
    Bricka, I had this very same problem with my newest Silencer. Give Joel a call at customer service (cracked TRG rod). He had me take a few pics of it and email to him. He had a replacement in the mail the same day. The melting look of the cables is more than likely your string wax gumming up. I didn't look at the links in the last post, but you can take that extra wax off with a piece of dental floss wrapped around the string then worked the length of the gummed up area....then rewax with one of the OTHER string waxes like Excellerator.

    Hope that helps!
    -2011 Martin Silencer 63# 29.5", Limbsaver prism elite .029 sight, Alpine Whisperflite drop away rest, Alpine 5 arrow quiver, G5 1/4" Meta Peep, Carbon Express 8" stabilizer, Gold Tip Warrior and Expedition Hunter (385gr), G5 Montec
    -2011 Martin Silencer, 73# 29.5", Limbsaver prism elite .019 sight, QAD Ultra Rest Pro LD, Tight Spot 5 arrow quiver, 1/4" G5 Meta peep, Carbon Express 8" stabilizer, Gold Tip Expedition Hunter 7595 camo (441gr), G5 Montec BH.

  4. #4
    Member
    Join Date
    May 2011
    Location
    Maryland
    Posts
    33
    Post Thanks / Like

    Default Trg

    Quote Originally Posted by mudpig View Post
    Bricka, I had this very same problem with my newest Silencer. Give Joel a call at customer service (cracked TRG rod). He had me take a few pics of it and email to him. He had a replacement in the mail the same day. The melting look of the cables is more than likely your string wax gumming up. I didn't look at the links in the last post, but you can take that extra wax off with a piece of dental floss wrapped around the string then worked the length of the gummed up area....then rewax with one of the OTHER string waxes like Excellerator.

    Hope that helps!
    I talked to him he just suggested that I take it to a Martin Dealer for them to get the part which I am going to today. Also I am going to pick up some of that Excellerator as well. With the old hoping I get it back has anyone tried to heat the glue up so you can get the old rod out and replace it with a standard 3/8" rod glued back in.

  5. #5
    String builder/ Super Moderator Hutch~n~Son Archery's Avatar
    Join Date
    Aug 2009
    Location
    Gilmanton, New Hampshire
    Posts
    5,787
    Post Thanks / Like

    Default

    Welcome to the forum!



    Hutch
    Bow String Depot Custom String Builders
    Need a string set pm or email me @ bowstringdepot@gmail.com
    or check us out @ http://bowstringdepot.com

  6. #6
    Banned
    Join Date
    May 2011
    Posts
    1,499
    Post Thanks / Like

    Default

    Glue?

  7. #7
    Member
    Join Date
    May 2011
    Location
    Maryland
    Posts
    33
    Post Thanks / Like

    Default Glue

    Quote Originally Posted by Destroyer View Post
    Glue?
    I am talking about the glue that connects the carbon rod to the slide unless it is epoxy

  8. #8
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,624
    Post Thanks / Like

    Default

    Quote Originally Posted by bricka View Post
    I am talking about the glue that connects the carbon rod to the slide unless it is epoxy
    I didn't know Martin was gluing them in. All the bows I've owned and seen they are held in with two small (1/8") set screws. Loosen them or remove them and wiggle the rod out. They can be pretty tight. Push the new rod in or if need be use a hammer/mallet to tap it in and reinstall the set screws.

    If it is glued in I would probably start by cutting it off close to the riser and using a small drill bit just drill it, working up to and finishing with a 3/8" bit. Then drill and tap two holes on the side to use set screws for the new one. Or maybe just one hole and set screw.
    If You're Not Living on the Edge You're Taking Up Too Much Space
    Martin Gold Plus Staff Shooter
    Alien Mafia
    PSAA Life member, UBP Life member
    PADI AOW Diver

  9. #9
    Senior Member
    Join Date
    Jan 2011
    Location
    SW OK
    Posts
    1,480
    Post Thanks / Like

    Default

    Barry

    The cable rod is glued into the TRG not the riser. I think you were thinking it is glued on the riser end?

    I asked Ryan about that the other night. He said they rod is too short to use a cable slide even if you could get the TRG off the rod.
    Firecat 400

  10. #10
    Super Moderator bfisher's Avatar
    Join Date
    Nov 2005
    Location
    Middletown, Pa, USA
    Posts
    11,624
    Post Thanks / Like

    Default

    Quote Originally Posted by MLN1963 View Post
    Barry

    The cable rod is glued into the TRG not the riser. I think you were thinking it is glued on the riser end?

    I asked Ryan about that the other night. He said they rod is too short to use a cable slide even if you could get the TRG off the rod.
    You're right. I misunderstood. A common fault of mine. I'm a little surprised it doesn't have set screws. It would allow for more adjustment. I do have to admit I haven't seen a bow with the TRG to make an objective decision on this.
    If You're Not Living on the Edge You're Taking Up Too Much Space
    Martin Gold Plus Staff Shooter
    Alien Mafia
    PSAA Life member, UBP Life member
    PADI AOW Diver

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •